Ticket #1000 (closed defect: fixed)

Opened 11 years ago

Last modified 11 years ago

Terminal starts in root, regardless of $HOME setting

Reported by: cwixon@… Owned by: buglog@…
Priority: high Milestone:
Component: openmoko-terminal Version: 2007.2
Severity: normal Keywords: VERIFIED
Cc: mickey@…, buglog@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible:

Description


Attachments

terminal-colors+startdir.patch (2.1 KB) - added by cwixon@… 11 years ago.
Patch for openmoko-terminal2 start directory and colors
openmoko-terminal2_svn.bb (266 bytes) - added by cwixon@… 11 years ago.
Revised bitbake recipe to bring in new patch.

Change History

comment:1 Changed 11 years ago by cwixon@…

Oops, my pinky finger pressed ENTER accidentally too early. Summary should be:

Terminal starts in root, regardless of $HOME setting

I don't see where to change this behavior -- the old terminal mrxvt had an
.mrxvtrc file in which to change settings, but where go settings in the new one?

Regardless of where settings are put, the default behavior should be for it to
start in the user's home directory, currently /home/root. But right now it
starts at /

comment:2 Changed 11 years ago by cwixon@…

  • Summary changed from Terminal starts in root, regardless of to Terminal starts in root, regardless of $HOME setting

comment:3 Changed 11 years ago by mickey@…

The terminal just duplicates what happens when you login from a remote shell. We
should change it in a generic way. How do other distributions do that?

comment:4 Changed 11 years ago by cwixon@…

  • Cc mickey@… added

Mickey, I missed your comment before I came up with a patch (I will submit it
shortly), which does two things:

  • startup in $HOME
  • hardcode a set of colors in which alsamixer can be used successfully (too

dim before)

This program probably needs a .openmoko-terminalrc file to read, or perhaps some
gconf entries, in which colors, font, etc. can be customized, but for the time
being, I think the patch helps usability. I'll code that up (.rc/gconf) if
you're otherwise too busy.

As to your 2007-11-14 comment, remote shells all seem to start in "~", in my
experience at least, so I have enforced the same behavior here via getenv(HOME)
and passing it to the terminal widget.

Attachments will be the patch plus the updated bitbake file, which can be
ignored if you make the patch in SVN.

Changed 11 years ago by cwixon@…

Patch for openmoko-terminal2 start directory and colors

Changed 11 years ago by cwixon@…

Revised bitbake recipe to bring in new patch.

comment:5 Changed 11 years ago by mickey@…

  • Status changed from new to closed
  • Resolution set to fixed

Interestingly I can't reproduce this problem anymore, even without your patch.
It seems like something changed in OE that fixed it. Anyways, I have applied
your patch (with slight changes) and will close this now. Please reopen if you
still have problems. Thanks!

comment:6 Changed 11 years ago by cwixon@…

  • Status changed from closed to reopened
  • Resolution fixed deleted

With openmoko-terminal2 2.1.1+svnr3435-r2 and libvte9 0.16.8-r3 installed, I
find myself back at "/" again.

Someone (not me) posted a screenshot at
http://scap.linuxtogo.org/files/ebd1d922ade13d1217e8f2456aa2dbda.png

Subsequent to submitting my earlier patch, I found that setting the directory in
the vte_terminal_fork_command call to "~" or "~/" did NOT work, but setting it
to "/home/root" did (of course), and so did setting it to getenv("HOME"). The
latter is probably preferable.

comment:7 Changed 11 years ago by mickey@…

Ok, let's try with getenv("HOME"). in r3542.

comment:8 Changed 11 years ago by mickey@…

  • Status changed from reopened to closed
  • Resolution set to fixed

Seems to work now.

comment:9 Changed 11 years ago by cwixon@…

  • Keywords VERIFIED added

This has been fixed for a while -- VERIFIED, and thanks!

Note: See TracTickets for help on using tickets.