Ticket #1005 (closed defect: fixed)

Opened 10 years ago

Last modified 9 years ago

U-boot passthrough does not work for current gsmd

Reported by: tick@… Owned by: openmoko_kernel
Priority: high Milestone:
Component: u-boot Version: current svn head
Severity: major Keywords:
Cc: buglog@…, balrogg@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: no PatchReviewResult:
Reproducible:

Description

According to Thomas, gsmd in current SVN does not support U-boot passthrough mode.

Change History

comment:1 Changed 10 years ago by sean_chiang@…

  • Status changed from new to assigned

comment:2 Changed 10 years ago by balrogg@…

  • bug_file_loc set to http://lists.openmoko.org/pipermail/openmoko-uboot/2007-September/000125.html
  • rep_platform changed from PC to Neo1973
  • Component changed from gsmd to u-boot
  • op_sys changed from Linux to All
  • Cc balrogg@… added

Reassigning to u-boot component as this is by no means a gsmd bug. It's a
problem in u-boot passthrough which will affect any serial port communication,
not only GSM. We proposed a fix back in Sept., which is posted at
http://lists.openmoko.org/pipermail/openmoko-uboot/2007-September/000125.html
with a bug description. It can also be worked around in gsmd (we have a patch)
but that's a wrong thing to do.

comment:3 Changed 10 years ago by sean_chiang@…

  • Owner changed from sean_chiang@… to sean_chiang@…
  • Status changed from assigned to new

comment:4 Changed 10 years ago by sean_chiang@…

Andrzej, I'm getting a bit confused, you mean this bug had already fixed in
u-boot and passthrough well work? I'm still have trouble with it now. :(

comment:5 Changed 10 years ago by sean_chiang@…

I got it, the uboot-openmoko doesn't apply the u-boot-dont-convert.patch yet. :)

comment:6 Changed 10 years ago by balrogg@…

Nope, the patch had no comments and wasn't applied, I think OpenEmbedded? doesn't
use it either, because u-boot is slightly unmaintained. I use this u-boot binary:
http://folks.o-hand.com/andrew/u-boot.udfu
But it's also not ideal because u-boot USB driver sometimes skips some packets
on heavy traffic (u-boot can't use interrupts).

comment:7 Changed 10 years ago by mickey@…

  • Severity changed from normal to major

updating the severity since fixing this would tremendously increase productivity

comment:8 Changed 10 years ago by sean_chiang@…

  • Status changed from new to assigned

comment:9 Changed 10 years ago by willie_chen@…

  • Owner changed from sean_chiang@… to willie_chen@…
  • Status changed from assigned to new

comment:10 Changed 9 years ago by roh

  • Owner changed from willie_chen@… to willie_chen

comment:11 Changed 9 years ago by john_lee

  • Owner changed from willie_chen to openmoko_kernel
  • Status changed from new to assigned
  • HasPatchForReview unset

willie_chen doesn't work for us anymore. Reassign to openmoko-kernel.

comment:12 Changed 9 years ago by mickey

  • Status changed from assigned to closed
  • Resolution set to fixed

Laf0rge has fixed this recently in u-boot/git.

Note: See TracTickets for help on using tickets.