Ticket #1015 (closed defect: fixed)

Opened 11 years ago

Last modified 11 years ago

quemu-neo1973 in r3444 fails to compile

Reported by: dinamich@… Owned by: balrogg@…
Priority: high Milestone:
Component: qemu-neo1973 Version: current svn head
Severity: normal Keywords:
Cc: buglog@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible:

Description

hi,

r3444 of trunk/src/host/qemu-neo1973 fails to build (make). Here is a patch to
make it compile and work (tested with openmoko/download.sh and openmoko/flash.sh):

xxxx@xxxx:~/openmoko-trunk/src/host/qemu-neo1973$ svn diff
Index: hw/usb.h
===================================================================
--- hw/usb.h (revision 3444)
+++ hw/usb.h (working copy)
@@ -112,6 +112,8 @@

typedef struct USBDevice USBDevice;
typedef struct USBPacket USBPacket;


+#include "qemu-common.h"
+

/* definition of a USB device */
struct USBDevice {

void *opaque;

Index: usb-linux-gadget.c
===================================================================
--- usb-linux-gadget.c (revision 3444)
+++ usb-linux-gadget.c (working copy)
@@ -815,6 +815,7 @@

#else
# include "hw/usb.h"

+# include "linux-user/errno_defs.h"

int usb_gadget_init(void)
{

Change History

comment:1 Changed 11 years ago by balrogg@…

  • Owner changed from dodji@… to balrogg@…

comment:2 Changed 11 years ago by balrogg@…

  • Status changed from new to closed
  • Resolution set to fixed

Thanks for the report, I forgot to add the qemu-common.h include for the case
when Gadget fs is disabled because I only tested with it enabled. I added this
include in r3445, but it seems the errno_defs.h line wasn't necessary. Please
test and reopen if you still see the issue.

comment:3 Changed 11 years ago by dinamich@…

Your fix in r3445 works.

Thanks.

Note: See TracTickets for help on using tickets.