Ticket #1041 (closed defect: community)

Opened 9 years ago

Last modified 8 years ago

Mediaplayer gets VBR mp3 durations incorrect

Reported by: cwixon@… Owned by: Abraxa
Priority: high Milestone:
Component: openmoko-mediaplayer Version: 2007.2
Severity: normal Keywords:
Cc: buglog@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: no PatchReviewResult:
Reproducible:

Description

I can't say whether this is true for fixed-bitrate files or not.

For VBR files, when looking at the main play screen, the elapsed time/total time
counter in the lower right corner acts strangely.

The elapsed time starts at zero and increments every second, as expected. But
the total time starts at an incorrect number and fluctuates, sometimes up,
sometimes down, as the track continues to play. Usually it starts from a
way-too-high number and drops quickly to a low number, then comes back up to the
correct value.

Change History

comment:1 Changed 9 years ago by abraxa@…

  • Status changed from new to assigned

comment:2 Changed 9 years ago by abraxa@…

The media player receives the track length through gstreamer's libmad plugin so
this isn't a media player issue per se. I'll have to check what can be done on
the libmad side as this most likely is the culprit here.

comment:3 Changed 9 years ago by olv@…

  • Status changed from assigned to new
  • Owner changed from abraxa@… to michael@…

comment:4 Changed 9 years ago by mickey@…

  • Owner changed from michael@… to abraxa@…

comment:5 Changed 9 years ago by cwixon@…

Does the player currently read the ID3v2 TLEN tag?

Right now, it looks like the initial xml playlist file includes just the file
URI and a guess at the title for each track (derived from the filename). Then
at some point the "creator"/title/duration entries get filled in, but the
duration (it appears) is a calculated value.

The files I'm using don't have that tag but it wouldn't be too difficult to add
them, I suppose, since I'm ripping everything from CD (and the online metadata
databases contain that info too, I believe).

comment:6 Changed 9 years ago by abraxa@…

  • Status changed from new to assigned

comment:7 Changed 9 years ago by roh

  • Owner changed from abraxa@… to Abraxa

comment:8 Changed 8 years ago by john_lee

  • Status changed from assigned to closed
  • HasPatchForReview unset
  • Resolution set to community
Note: See TracTickets for help on using tickets.