Ticket #1044 (closed defect: worksforme)

Opened 11 years ago

Last modified 2 years ago

calc_next_timeout 't' assert failure.

Reported by: robophred@… Owned by: mickeyl
Priority: high Milestone:
Component: neod Version: current svn head
Severity: normal Keywords:
Cc: buglog@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible:

Description

Was running the qemu emulator from the makefile, compiled today.
Was playing "bridges", had an assert failure show up when I selected "new game"
after having played through several games.

The x server died, and the console read (might not be exact, retyping from qemu):

(neod:1174): DEBUG: stylus pressed
neod: pulse/mainloop.c:739: calc_next_timeout: Assertion `t' failed.
matchbox-keyboard-remote.c:35,mb_kbd_remote_process_xevents() got a message

matchbox-keyboard-remote.c:35,mb_kbd_remote_process_xevents() got a message

matchbox-keyboard-remote.c:35,mb_kbd_remote_process_xevents() got a message

run-parts: /etc/X11/Xsession.d/90xXWindowManager exited because of uncaught
signal 6: Success
FreeFontPath?: FPE "built-ins" refcount is 2, should be 1; fixing.
Extended Input Devices not yet supported. Implement it at line 637 in kinput.c
FreeFontPath?: FPE "built-ins" refcount is 2, should be 1; fixing.
PM: Removing info for No Bus:vcs3
PM: Removing info for No Bus:vcsa3

PM: Removing info for No Bus:vcs2
PM: Removing info for No Bus:vcsa2

Attachments

bug 2 specific.jpg (72.5 KB) - added by robophred@… 11 years ago.
jpeg image of terminal after error

Change History

comment:1 Changed 11 years ago by robophred@…

Just had a second occurrence. Same setup as last time, occured after playing
around with the bridges game of oh-puzzles.

Was able to find the code in question in the pulseaudio svn. Error seems to
occur when the function "find_next_time_event" returns null.

Changed 11 years ago by robophred@…

jpeg image of terminal after error

comment:2 Changed 11 years ago by mickey@…

This is very hard to reproduce. Maybe it's a problem in some of the puzzle games.

comment:3 Changed 11 years ago by roh

  • Owner changed from mickey@… to mickeyl

comment:4 Changed 11 years ago by mickeyl

  • Status changed from new to closed
  • Resolution set to worksforme

could not reproduce.

comment:5 Changed 2 years ago by Chassmetly

Shipped Ups Isotretinoin <a href=http://zol1.xyz/cheapest-zoloft-online.php>Cheapest Zoloft Online</a> Amoxicillin Induce Cyp2d6 Rx Pills Com <a href=http://kama1.xyz/kamagra-jellies.php>Kamagra Jellies</a> Salzarex Pharmaceuticals Generic Viagra Viagra Per Donne Acquisto <a href=http://cial5mg.xyz/need-to-order-cialis.php>Need To Order Cialis</a> Acheter Cialis Generique Belgique Celebrex Discount Card <a href=http://zol1.xyz/map.php>Zoloft Online Usa</a> Order Levitra At Walmart Cheap Cialis Online Canadian P <a href=http://cial1.xyz/buy-cialis.php>Buy Cialis</a> Levitra Erezione Mex Pharmacy <a href=http://cial5mg.xyz/cialis-20mg-price.php>Cialis 20mg Price</a> Cheapest Accutane 40 Mg Buying Viagra <a href=http://zol1.xyz/buy-zoloft-online-usa.php>Buy Zoloft Online Usa</a> Original Viagra Kaufen Cialis 60 <a href=http://nolvadex.ccrpdc.com/nolvadex-20mg.php>Nolvadex 20mg</a> Tadacip Online No Prescription Amoxicillin For Cat <a href=http://cial1.xyz/shop-cialis-online.php>Shop Cialis Online</a> Baclofene Rennes Viagra Online Pay With Paypal <a href=http://viag1.xyz/buy-cheap-viagra.php>Buy Cheap Viagra</a> Genraic Viagra For Men Cialis 20 Prezzo <a href=http://cial1.xyz/tadalafil-online.php>Tadalafil Online</a> Viagra Brand 100mg Is Cephalexin For Throat <a href=http://viag1.xyz/real-viagra-online.php>Real Viagra Online</a> Cheap Synthroid No Prescription Punarnava <a href=http://cial1.xyz/cialis-free-trial.php>Cialis Free Trial</a> Kamagra Sur Femme Buy Cialis 5mg Online Pharmacy <a href=http://zol1.xyz/cheap-zoloft-generic.php>Cheap Zoloft Generic</a> Kamagra Efectos Colaterales You owe it to yourself to get the Best Guaranteed deal possible. <a href=http://newcashloan356.com>paydayloans</a> Go to site More How does repaying the loan work Tennessee Kabbage What if Im late repaying the loan USA Payday Cash Weekend Payday Loans No Credit Check Payday Loans Posted July th and last modified February th NetLoanUSA No credit checks.DCB Bank a private lender has tied up with institutions such as the Birla Institute of Technology Science Pilani Rajasthan to launch entrepreneurship programmes. The law of your able to repay any amount that you borrow.Progesterone Website <a href=http://viag1.xyz/viagra-discount-sales.php>Viagra Discount Sales</a> Order Topamax Online Paypal Viagra Deutsche Apotheke <a href=http://kama1.xyz/best-generic-kamagra.php>Best Generic Kamagra</a> Clomid Contre Indications

Note: See TracTickets for help on using tickets.