Ticket #1062 (closed defect: fixed)

Opened 11 years ago

Last modified 11 years ago

gsmd doesn't provide a way to know when an incoming call has hung up before being accepted

Reported by: mickey@… Owned by: chris@…
Priority: high Milestone:
Component: openmoko-dialer Version: unspecified
Severity: critical Keywords:
Cc: buglog@…, balrogg@…, tick@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible:

Description

To reproduce:

Call your Neo until it rings. Hang up on the calling station. Neo Dialer does
not recognize it.

Change History

comment:1 Changed 11 years ago by balrogg@…

  • Cc balrogg@… added
  • rep_platform changed from PC to Neo1973

I once looked into this a couple of weeks ago and I didn't find any way to
enable any kind of notification from modem when the peer hangs up, but very
likely I haven't been looking close enough (perhaps +CPI:.. ?). Instead I added
a timer that fires when there's no +CRING for two seconds and notfies gsmd
clients. The commit id was aba18c571f07e8467dac488a3ca0697002628d9c in the gsmd
tree at http://folks.o-hand.com/andrew/gsmd.git, it also fixes a couple of other
issues.

comment:2 Changed 11 years ago by thomas@…

  • Cc tick@… added

Tick, perhaps you could comment on whether you think the time out should be
implemented on the gsmd side or the client side?

comment:3 Changed 11 years ago by tick@…

The version of aba18c571f07e8467dac488a3ca0697002628d9c on
http://folks.o-hand.com/andrew/gsmd.git
is dealing with RING timeout but not +CRING timeout.

This patch is committed as R3572.

It works for gsmd with AT+CRC=0 && without AT%CPI=2 or 3
Currently gsmd use the %CPI information to tell if a call is disconnected.

A timeout scheme of +CRING is still needed if another modem, without %CPI
support, is used.

comment:4 Changed 11 years ago by sean_chiang@…

  • Owner changed from thomas@… to chris@…

comment:5 Changed 11 years ago by sean_chiang@…

  • Severity changed from normal to critical

comment:6 Changed 11 years ago by chris@…

  • Status changed from new to closed
  • Resolution set to fixed
  • Summary changed from While ringing, dialer does not recognize when peer hangs up to gsmd doesn't provide a way to know when an incoming call has hung up before being accepted

Dialer bug re-filed in 1153 with patch attached, changing this bug to represent
the underlying issue which has long since been fixed.

Note: See TracTickets for help on using tickets.