Ticket #1076 (closed defect: fixed)

Opened 11 years ago

Last modified 11 years ago

extrsp_parse() get confused when the last filed of input is number

Reported by: sean_chiang@… Owned by: sean_chiang@…
Priority: high Milestone:
Component: gsmd Version: unspecified
Severity: normal Keywords:
Cc: buglog@…, tick@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible:

Description


Attachments

extrsp_parse.patch (618 bytes) - added by sean_chiang@… 11 years ago.
make extrsp_parse() can take care another input

Change History

comment:1 Changed 11 years ago by sean_chiang@…

  • Status changed from new to assigned

Changed 11 years ago by sean_chiang@…

make extrsp_parse() can take care another input

comment:2 Changed 11 years ago by sean_chiang@…

For example, extrsp_parse can't process this respond +CLCC:
2,1,5,0,0,"02xxxxxxx",129

comment:3 Changed 11 years ago by tick@…

  • Status changed from assigned to closed
  • Resolution set to fixed

The patch works for me.
commit as R3558

Note: See TracTickets for help on using tickets.