Ticket #1088 (closed defect: fixed)

Opened 9 years ago

Last modified 9 years ago

Move production test code out of U-Boot into kernel module

Reported by: andy@… Owned by: openmoko-kernel
Priority: highest Milestone:
Component: production testing Version:
Severity: normal Keywords:
Cc: buglog@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: no PatchReviewResult:
Reproducible:

Description

Supporting the PBE kernel and the U-Boot codebase is less good than supporting
one environment for all the purposes, the shipping kernel.

Migrate any testing stuff that is in PBE or U-Boot world instead into modules
for the current shipping kernel, and generally favour adding test stuff into
the kernel rather than U-Boot so there is less to maintain outside of the one
kernel.

Change History

comment:1 Changed 9 years ago by andy@…

  • Owner changed from sean_chiang@… to willie_chen@…

comment:2 Changed 9 years ago by roh

  • Owner changed from willie_chen@… to willie_chen

comment:3 Changed 9 years ago by john_lee

  • Status changed from new to assigned
  • HasPatchForReview unset
  • Component changed from Core System to production testing
  • Priority changed from high to normal
  • Version GTA02v2 deleted
  • Owner changed from willie_chen to openmoko-kernel

Is this still valid?

comment:4 Changed 9 years ago by andy

  • Status changed from assigned to closed
  • Priority changed from normal to highest
  • Resolution set to fixed

GTA02 testing has had it, it is stuck with current system.

For GTA03, U-Boot has been deprecated and there is an effort underway in Taipei by Chris Hall to provide a script-based verify and test framework with all actions done in a Linux rootfs and captured into scripts.

So I'm going to say it's fixed because whatever happens U-Boot isn't coming back in our production action.

Note: See TracTickets for help on using tickets.