Ticket #1092 (closed defect: fixed)

Opened 11 years ago

Last modified 10 years ago

gllin outputs uncompressed NMEA log, crashes on disk full

Reported by: mjr@… Owned by: mickey
Priority: high Milestone:
Component: gllin Version: 2007.2
Severity: normal Keywords:
Cc: buglog@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: no PatchReviewResult:
Reproducible:

Description

The gllin as packaged seems to output uncompressed NMEA log into
/home/root/gllin/log (in addition to the gzipped log that's started in the
wrapper script, apparently because gllin would crash if there was no reader).
This fills up the internal flash in relatively short order as well as does extra
writes that we don't need on the flash. Also, the crash that results from not
being able to write said log is rather uninformative.

Fortunately, this one is mostly a matter of a command line parameter; gllin
should be given -nmea in the latter startup command in the wrapper script.
(gllin -h claims this is the default, but that seems to be inaccurate.)

(Personally, I just replaced the cat as well with a pipe to /dev/null, but
that's me.)

Change History

comment:1 Changed 11 years ago by laforge@…

  • Owner changed from laforge@… to mickey@…

comment:2 Changed 11 years ago by roh

  • Owner changed from mickey@… to mickeyl

comment:3 Changed 11 years ago by roh

  • Owner changed from mickeyl to mickey

comment:4 Changed 10 years ago by mickey

  • Status changed from new to closed
  • HasPatchForReview unset
  • Resolution set to fixed

Fixed meanwhile with a newer package.

Note: See TracTickets for help on using tickets.