Ticket #1121 (closed defect: fixed)

Opened 11 years ago

Last modified 2 years ago

Editing contact data is impossible due to keyboard holding down the 'return' key

Reported by: cayco@… Owned by: erin_yueh@…
Priority: high Milestone:
Component: openmoko-keyboard Version: 2007.2
Severity: normal Keywords:
Cc: buglog@…, graeme@…, erin_yueh@…, chris@…, kevin@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible:

Description

It might be connected with #1120. When I try to edit contact (even with one phone number) edit field gets
constantly focus and unfocused which makes it impossible to edit.

Change History

comment:1 Changed 11 years ago by erin_yueh@…

  • Cc chris@… added
  • Owner changed from thomas@… to chris@…

hi Chris, could you please check this bug? it's about multiple phone numbers in
one record. If you have any question, please let me know. Thanks, Erin.

comment:2 Changed 11 years ago by cayco@…

Erin - is it? I does not work for me even for one number in record.

comment:3 Changed 11 years ago by chris@…

I've seen this before, but it doesn't happen for me in latest Contacts - Can you
verify that you're running the latest version?

comment:4 Changed 11 years ago by cayco@…

Today I upgraded to
Downloading http://buildhost.automated.it/OM2007.2/packages/armv4t/openmoko-
contacts2_0.1.0+svnr387-r4_armv4t.ipk

steps to reproduce:

edit contact
write something in phone number field
press return

telephone number starts focus (being selected) and unfocus.

comment:5 Changed 11 years ago by chris@…

  • Owner changed from chris@… to mickey@…
  • Component changed from openmoko-contacts to openmoko-keyboard
  • Summary changed from Editing contact data is impossible to Editing contact data is impossible due to keyboard holding down the 'return' key

Ah, this is a problem with either matchbox-keyboard or the keymap for it (more
likely the latter, we experience no problems with it in poky or other contexts),
as it is holding down return instead of just pressing it. Editing bug
description and reassigning.

I didn't experience it as I've not been using matchbox-keyboard.

comment:6 Changed 11 years ago by cayco@…

What keyboard are you using and how to switch to it? If is workaround to this bug it could be helpful to
know.

comment:7 Changed 11 years ago by chris@…

I'm using my own hacked up multi-tap input pad: http://chrislord.net/files/moko/
, http://chrislord.net/blog/Software/multitap-pad.enlighten

It conflicts with matchbox-keyboard-inputmethod, so you'll need to alter your
images/force options accordingly. It's a little hacky/buggy as I only knocked it
up in a day or two and haven't gone back to it, but I find it far more useful
than a QWERTY keyboard.

comment:8 Changed 11 years ago by erin_yueh@…

  • Owner changed from mickey@… to erin_yueh@…

this bug is similar to bug#1146 and it's our keyboard problem.
Raster will implement a new keyboard for us. When he is done, we can fix this bug.

comment:9 Changed 11 years ago by chris@…

  • Cc graeme@… added

* Bug 1146 has been marked as a duplicate of this bug. *

comment:10 Changed 11 years ago by erin_yueh@…

  • Cc erin_yueh@… added

comment:11 Changed 11 years ago by erin_yueh@…

  • Status changed from new to assigned

comment:12 Changed 11 years ago by thomas@…

  • Cc kevin@… added

* Bug 1188 has been marked as a duplicate of this bug. *

comment:13 Changed 11 years ago by erin_yueh@…

  • Status changed from assigned to closed
  • Resolution set to fixed

mark it to fixed. we can use multi-tap key pad

comment:14 Changed 2 years ago by RoberMync

Viagra Generique Acheter <a href=http://viag1.xyz/real-viagra-online.php>Real Viagra Online</a> Comprar Viagra Sin Receta Contrareembolso Kamagra En Andalucia <a href=http://cial1.xyz/cialis-cheap.php>Cialis Cheap</a> Netherlands Online Pharmacy Amoxicillin Clar <a href=http://viagra.ccrpdc.com/order-cheap-viagra.php>Order Cheap Viagra</a> How Much Does Viagra Cost Per Pill 337 Can You Take Expiered Amoxicillin <a href=http://accutane.ccrpdc.com/how-to-buy-accutane.php>How To Buy Accutane</a> Priligy Online L Thyroxine <a href=http://cial5mg.xyz/cialis-40mg.php>Cialis 40mg</a> Comprar Cialis Tadalafil Viagra En Barcelona Precio <a href=http://cytotec.ccrpdc.com/cytotec-tablet.php>Cytotec Tablet</a> Kamagra Kaufen Nachnahme Comprar Viagra Sin Receta Madrid <a href=http://kama1.xyz/generic-kamagra-pills.php>Generic Kamagra Pills</a> Paroxetine 30mg Online India Pharmacy Cialis Online Us <a href=http://zol1.xyz/buy-zoloft-on-line.php>Buy Zoloft On Line</a> Cialis O Viagra O Levitra secure ordering isotretinoin with free shipping direct <a href=http://cial5mg.xyz/shop-cialis-online.php>Shop Cialis Online</a> Get Cialis Without Presecription Isotretinoin Discount Fedex Shipping Glasgow <a href=http://kama1.xyz/kamagra-online.php>Kamagra Online</a> Amoxicillin High Dose Prescription Levitra Achat <a href=http://kama1.xyz/prices-kamagra.php>Prices Kamagra</a> Daily Cialis Sales Proscar <a href=http://cial5mg.xyz/shop-cialis-online.php>Shop Cialis Online</a> Finasteride Uk Buy Propecia Buy Xenical Slimming Pills <a href=http://cial1.xyz/buy-cheap-cialis-site.php>Buy Cheap Cialis Site</a> Order Propecia Finasteride Cialis Farmaco <a href=http://lasix.ccrpdc.com/buying-lasix-online.php>Buying Lasix Online</a> Levitra Medicine Cialis 20mg Filmtabletten Einnahme <a href=http://cial1.xyz/cialis-cost.php>Cialis Cost</a> Cheap Zithromax Keflex In Renal Impairment <a href=http://kama1.xyz/kamagra-buy-online.php>Kamagra Buy Online</a> Amoxicillin Is Used For Amoxicillin Doseage <a href=http://viag1.xyz/best-viagra-online.php>Best Viagra Online</a> Isotretinoin 20mg acne in internet with doctor consult How To Order Flagyl In Hampton <a href=http://viag1.xyz/viagra.php>?Viagra</a> 5 Mg Cialis Propecia En Falta <a href=http://kama1.xyz/buy-cheap-generic-kamagra.php>Buy Cheap Generic Kamagra</a> Priligy Precio En Peru Buy Doxycycline In Usa <a href=http://cytotec.ccrpdc.com/cytotec-misoprostol.php>Cytotec Misoprostol</a> Venta Libre De Kamagra Propecia Espana Receta Medica <a href=http://cial1.xyz/cialis-5mg.php>Cialis 5mg</a> 5mg Cialis From India Cephalexin Dermatitis <a href=http://cial5mg.xyz/buy-cialis-online-usa.php>Buy Cialis Online Usa</a> Viagra Naturel Viagra Original 50 Mg <a href=http://zol1.xyz/zoloft-generic-name.php>Zoloft Generic Name</a> Vagra Securedrugshop <a href=http://cial1.xyz/order-cialis-pills.php>Order Cialis Pills</a> Venta Cialis Correo Cheap Generic Cialis Free Shipping <a href=http://zol1.xyz/buy-zoloft-online-cheap.php>Buy Zoloft Online Cheap</a> Xenical Orlistat Buy Online Uk Cialis Precio Oficial <a href=http://viag1.xyz/viagra-free-trial.php>Viagra Free Trial</a> Clomid For Pct Kamagra Spray <a href=http://zol1.xyz/buy-zoloft-on-line.php>Buy Zoloft On Line</a> Cod Only Acticin Scabies Where To Purchase Medication Cours Du Levitra <a href=http://viag1.xyz/online-viagra.php>Online Viagra</a> Achat De Lioresal Loan amounts differ at Florida InstaLoan? locations.These sites will typically make money by charging businesses everytime you interact with the business via their site and giving you a portion of the fee. <a href=http://money-loan-today.com>poor credit loans</a> I kept paying and paying but all the money I paid was just the interest she said.Isotretinoin Where To Purchase <a href=http://cialis.ccrpdc.com/brand-cialis-online.php>Brand Cialis Online</a> buy accutane online no prescription Cheap Generic Cipro <a href=http://inderal.ccrpdc.com/buy-online-propranolol.php>Buy Online Propranolol</a> Cytotec Et Pose De Implant Doryx Where Can I Buy Medication Visa Accepted <a href=http://zol1.xyz/zoloft-free-offer.php>Zoloft Free Offer</a> Panamycin Buy Viagra Without Prescription' <a href=http://viag1.xyz/buying-viagra-online.php>Buying Viagra Online</a> Cialis Modo De Empleo Viagra Jelly Online Uk <a href=http://cial1.xyz/cheap-generic-cialis.php>Cheap Generic Cialis</a> Lioresal Commander 25mg Acheter Cialis Fiable <a href=http://zol1.xyz/online-zoloft.php>Online Zoloft</a> Propecia Gleicher Wirkstoff Cialis Effetti <a href=http://kama1.xyz/kamagra-order.php>Kamagra Order</a> Levitra Uso Diario Priligy Janssen Cilag <a href=http://cial1.xyz/cheap-cialis.php>Cheap Cialis</a> Viagra Made In Canada Efficacia Propecia 5 Alfa Reduttasi <a href=http://kama1.xyz/kamagra-jelly-usa.php>Kamagra Jelly Usa</a> Astuces Pour Durer Plus Longtemps

Note: See TracTickets for help on using tickets.