Ticket #1124 (closed enhancement: fixed)

Opened 11 years ago

Last modified 20 months ago

automatic script to setup qemu network connection.

Reported by: john_lee@… Owned by: balrogg@…
Priority: high Milestone:
Component: qemu-neo1973 Version: unspecified
Severity: minor Keywords:
Cc: buglog@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible:

Description

Hi Andrzej,

Could you please provide a convenient script to setup network connection to qemu
like what you described at

http://wiki.openmoko.org/wiki/Qemu#Simple_network_connection_with_pppd

Change History

comment:1 Changed 11 years ago by balrogg@…

Sorry, was away from keyboard for last days.

The thing with setting up network is that it requires root access. Switching
users is not easily done in scripts and is system-specific (on some distros
there's no root password by default so "su" doesn't work and you have to use
sudo or even something else).

qemu-neo1973 at the moment emulates GTA01. GTA01 had no network card as such
and this is why standard qemu networking options don't apply. GTA02 has a WLAN
card so networking should work out-of-the-box without any setting up, like with
normal QEMU. I propose waiting until we have a stable WLAN kernel driver and
WLAN emulation. WLAN emulation should be available soon.

Currently I am missing some crucial documentation/hardware to implement some
bits, but it shouldn't be long till this is resolved.
The pppd chapter in the wiki was written by Tuukkaa (I should give credit :p ).

comment:2 Changed 11 years ago by john_lee@…

  • Status changed from new to closed
  • Resolution set to fixed

<quote from Andrzej's mail:>

openmoko/qemu-auto.sh

launches qemu and opens a unix socket for communication. All

additional parameters are passed to qemu. (e.g. openmoko/qemu-auto.sh
-nographic launches the virtual machine with no graphics etc.).

openmoko/qemu-upload.sh <filename>

produces a SD card image with one partition with the given file(s)

on it (you can pass a list of files) and inserts it into the phone.
The OpenMoko? kernel should detect the event and the automounter should
mount the partition. openmoko/qemu-auto.sh must be running already. If
you pass no parameters, it ejects the media (the OM kernel is too dumb
to detect this unfortunately). This will only work with gta01
emulation because gta02 has no SD.

openmoko/qemu-quit.sh

powers the VM down cleanly.

openmoko/qemu-gadget.sh

attempts to connect target's S3C USB slave to host's dummy HCD (if

present and gadgetfs is mounted).

comment:3 Changed 21 months ago by RonDert

Rxhealth http://cialtobuy.com - cialis Viagra Online Fast Delivery
Alprostadil Cream
Vente Cialis En Ligne <a href=http://cialtobuy.com >cialis</a> Wirkung Viagra Mann

comment:4 Changed 20 months ago by JeffRipt

Compre Viagra http://cialtobuy.com - cialis price Levitra Quand Le Prendre
Buy Now Legally Tab Doryx Free Shipping Store
Description Amoxil <a href=http://cialtobuy.com >cialis</a> Clobetasol By Money Order

Note: See TracTickets for help on using tickets.