Ticket #1131 (closed defect: community)

Opened 10 years ago

Last modified 5 months ago

SIM does not register with network

Reported by: tschlabach@… Owned by: sean_chiang
Priority: high Milestone:
Component: GSM Modem Version: GTA01Bv4
Severity: major Keywords:
Cc: buglog@…, erin_yueh@…, tilman.klar@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: no PatchReviewResult:
Reproducible:

Description

Hi!

I have two SIM cards, one pretty recent from T-Mobile and an older one (from the
early days of UMTS, at least 2-3 years old). While the T-Mobile card works fine
(i.e. I am asked for a PIN and the phone registers with the network afterwards)
when I try to use the Vodafone SIM, I am not asked for a PIN at all.

I'll attach the gsm.log.

Regards,
Torsten

Attachments

gsm.log (44.1 KB) - added by tschlabach@… 10 years ago.
gsm.log from trying to register with Vodafone SIM
gsm.2.log (57.4 KB) - added by tschlabach@… 10 years ago.
gsm.log from successfully registering with T-Mobile SIM (last part of file)
gsm.3.log (7.9 KB) - added by tilman.klar@… 10 years ago.
gsm.log when trying to register using my t-mobile simcard

Change History

Changed 10 years ago by tschlabach@…

gsm.log from trying to register with Vodafone SIM

Changed 10 years ago by tschlabach@…

gsm.log from successfully registering with T-Mobile SIM (last part of file)

comment:1 Changed 10 years ago by tick@…

  • Owner changed from sean_chiang@… to sean_chiang@…

comment:2 Changed 10 years ago by sean_chiang@…

  • Status changed from new to assigned

comment:3 Changed 10 years ago by sean_chiang@…

HI!! I saw the gsmd log of Vodafone SIM

Sun Dec 2 22:18:26 2007 <1> atcmd.c:329:ml_parse() extd reply `+CREG: 3' to cmd
`+COPS=0', must be unsolicited
Sun Dec 2 22:18:26 2007 <1> unsolicited.c:69:usock_evt_send() entering evt=5
Sun Dec 2 22:18:26 2007 <1> usock.c:55:usock_cmd_enqueue() enqueueing usock cmd
0x2fb40 for user 0x2f968
Sun Dec 2 22:18:26 2007 <1> usock.c:55:usock_cmd_enqueue() enqueueing usock cmd
0x2fba8 for user 0x2f7c8
Sun Dec 2 22:18:26 2007 <1> usock.c:1121:gsmd_usock_user_cb() successfully sent
cmd 0x2fba8 to user 0x2f7c8, freeing
Sun Dec 2 22:18:26 2007 <1> usock.c:1121:gsmd_usock_user_cb() successfully sent
cmd 0x2fb40 to user 0x2f968, freeing
Sun Dec 2 22:18:26 2007 <1> atcmd.c:260:ml_parse() buf=`+CME ERROR: 32'(14)
Sun Dec 2 22:18:26 2007 <1> atcmd.c:309:ml_parse() error number 32

The error number 32 means "network not allowed - emergency calls only". I wonder
maybe the signal is too low to register your home operator and you didn't
enable the roaming service. Could you try it again using the same sim with the
other phone at the same place.

comment:4 Changed 10 years ago by tschlabach@…

Hi Sean!

I tried that in different places and in all of them, the signal was perfect. I
am sure because the Vodafone SIM is my day-to-day SIM. So whenever I tried, I
took if of my normal phone, place it in the Neo, tried, and took it back and
booked into Vodafone again.

BTW: In Germany there is hardly any roaming inside the country. You can use a
foreign SIM card in Germany to be a roaming guest on a German network or you can
use your German SIM card abroad to be a roaming guest on a network in another
country.

Thinking again ...

The error number 32 means "network not allowed - emergency calls only".

As the phone did not ask me for the PIN and I did not enter it, I guess the SIM
card failed to provide the whatever secret it would provide (sorry, I am not
sure about terminology here) to authenticate me against the network.

I think the question is: Why am I not asked to enter a PIN? What event on the
GSM module makes the application layer pop up the "please enter your PIN" window
on the phone?

Regards,
Torsten

comment:5 Changed 10 years ago by sean_chiang@…

HI!Torsten,

You'll be asked enter PIN code if you use this newer image.You could download it
from:
http://people.openmoko.org/sean_chiang/rootfs/OpenMoko-openmoko-devel-image-glibc-ipk-P1-Snapshot-20071221-fic-gta01.rootfs.jffs2.

comment:6 Changed 10 years ago by erin_yueh@…

  • Cc erin_yueh@… added

comment:7 Changed 10 years ago by tschlabach@…

Sorry, no luck.

I flashed the phone with the image you linked, but it's still not asking the PIN
number for the Vodafone SIM. It says "Registering ..." in the top of the display
for some minutes now, but doesn't ask when using the Vodafone SIM card.

Besides that, I don't have icons anymore, just Xs.

T-Mobile is still fine, though no icons as well.

Shall I do a trace again?

comment:8 Changed 10 years ago by tilman.klar@…

  • Cc tilman.klar@… added

comment:9 Changed 10 years ago by tilman.klar@…

I suffer from the same problem, using a german T-Mobile SIM card. When trying to
manually use GSM by means of 'cu', nothing works as expected. Anyhow, I'll just
attach the current gsm.log (made with the rootfs from comment #5) - maybe one of
you guys knows what to do..

Changed 10 years ago by tilman.klar@…

gsm.log when trying to register using my t-mobile simcard

comment:10 Changed 10 years ago by tilman.klar@…

On second thought, it seems like I ran into a different problem. I reported an
own bug for that: http://bugzilla.openmoko.org/cgi-bin/bugzilla/show_bug.cgi?id=1232

comment:11 Changed 9 years ago by roh

  • Owner changed from sean_chiang@… to sean_chiang

comment:12 Changed 9 years ago by john_lee

  • Status changed from assigned to closed
  • HasPatchForReview unset
  • Resolution set to community

comment:14 Changed 5 months ago by Chassmetly

Type 1 Diabetes Propecia <a href=http://cial5mg.xyz/fast-delivery-cialis.php>Fast Delivery Cialis</a> Cialis Eccipienti Topills Online Pharmacy <a href=http://viag1.xyz/canadian-viagra.php>Canadian Viagra</a> Cialis Apothekenpreis On Line Acticin Internet <a href=http://cial5mg.xyz/ordina-cialis-online.php>Ordina Cialis Online</a> Levitra Dosage Vente Baclofen 25mg <a href=http://viag1.xyz/generic-viagra.php>Generic Viagra</a> Acheter Phenergan Viagra Rezeptfrei Bestellen Gunstig <a href=http://kama1.xyz/order-kamagra-gel.php>Order Kamagra Gel</a> Clomid Et Duphaston 2008 Viagra Pressione Alta <a href=http://kama1.xyz/order-kamagra-gel.php>Order Kamagra Gel</a> Amoxicillin Use In Cats Can Collies Take Keflex And Tramadol <a href=http://cial5mg.xyz/cialis-5mg.php>Cialis 5mg</a> Is Cialis Cheaper Than Viagra Cheapest Price For Cialis <a href=http://zol1.xyz/map.php>Zoloft Online Usa</a> Buy Synthroid Without A Script Amoxicillin And Alchole <a href=http://viag1.xyz/china-viagra-online.php>China Viagra Online</a> Generique Du Cialis En France Kamagra Oral Jelly Buono <a href=http://antabuse.ccrpdc.com/buying-antabuse-online.php>Buying Antabuse Online</a> Candianpharmacies Kamagra Customer Reviews <a href=http://cial1.xyz/how-to-order-cialis.php>How To Order Cialis</a> Durer Plus Longtemps Chambres Achat Rapide Kamagra <a href=http://zol1.xyz/implicane-online.php>Implicane Online</a> Viagra 100 Cheap

Note: See TracTickets for help on using tickets.