Ticket #1165 (closed defect: fixed)

Opened 11 years ago

Last modified 11 years ago

The console-only applications fail to start in terminal from menu

Reported by: audriusa@… Owned by: mickey@…
Priority: normal Milestone:
Component: openmoko-terminal Version: 2007.2
Severity: major Keywords:
Cc: buglog@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible:

Description

We are porting the console only application to OpenMoko? and have produced the
normal .ipk installer that creates the icon in the application menu. This
icon, however, fails to start the actual application: after some running (the
process "eye" is rolling) it silently terminates.

The application actually installs with our .ipk file and can be easily started
from the pre-opened terminal by typing its name ('mathomatic'). The
configuration file (mathomatic.desktop) has the flag terminal=true but this
seems not helpful. The configuration file is installed and respected because
the icon is found, loaded and shown.

To reproduce, download the .ipk file from the ommathomatic project and observe
the describe behavior.

I think that the command line support is important to the open source - based
phone. Such applications are less user friendly but they are rather widespread
and may be easier to port.

Attachments

openmoko-terminal2-patch-g-option-simple.diff (1.4 KB) - added by haakeyar-mailinglists@… 11 years ago.
Sorry, attached to the wrong bug.

Change History

comment:1 Changed 11 years ago by haakeyar-mailinglists@…

  • dependson set to 1177

At the moment, openmoko-terminal2 doesn't support any command-line options, so
you can't give it commands that should be run. This is described in #1177
and would need to be fixed before this can be fixed.

comment:2 Changed 11 years ago by mickey@…

  • Status changed from new to assigned

-e <command> is now supported in openmoko-terminal. Please check whether this
fixes your issue.

comment:3 Changed 11 years ago by mickey@…

  • Status changed from assigned to new
  • Owner changed from buglog@… to mickey@…

Changed 11 years ago by haakeyar-mailinglists@…

Sorry, attached to the wrong bug.

comment:4 Changed 11 years ago by haakeyar-mailinglists@…

  • attachments.description changed from Simple patch that implements -e/--command options. to Sorry, attached to the wrong bug.
  • attachments.isobsolete changed from 0 to 1

comment:5 Changed 11 years ago by mickey@…

can we close this now or do we need -x for this as well?

comment:6 Changed 11 years ago by mickey@…

  • Status changed from new to closed
  • Resolution set to fixed

-x is now supported as well (revision 4039).

Note: See TracTickets for help on using tickets.