Ticket #1180 (closed defect: fixed)

Opened 11 years ago

Last modified 11 years ago

helloworld doesn't build out-of-the-box on ubuntu

Reported by: hexmode@… Owned by: mickey@…
Priority: high Milestone:
Component: OE bitbake recipes / build system Version: unspecified
Severity: normal Keywords:
Cc: buglog@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible:

Description

There is a bashism in helloworld_1.0.0.bb. The line beginning with:

echo -e "#include ....

inserts "-e #include ..." as the first line in helloworld.c.

This is because /bin/sh on ubuntu is not bash and /bin/sh's echo does not
support -e.

Change History

comment:1 Changed 11 years ago by rod@…

  • Owner changed from rod@… to mickey@…
  • Component changed from MokoMakefile to OE bitbake recipes / build system

comment:2 Changed 11 years ago by john_lee@…

  • Status changed from new to closed
  • Resolution set to fixed

echo -e is gone now.

Note: See TracTickets for help on using tickets.