Ticket #1187 (closed defect: fixed)

Opened 11 years ago

Last modified 10 years ago

chgstate gives incorrect output (fix)

Reported by: andrew.paulsen@… Owned by: willie_chen@…
Priority: high Milestone:
Component: kernel Version: 2007.2
Severity: normal Keywords:
Cc: buglog@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible:

Description

cat /sys/devices/platform/s3c2410-i2c/i2c-adapter/i2c-0/0-0008/chgstate

results in output like this:
<NULL> fast_enabled present <NULL>

because the array of strings is being indexed incorrectly.

Attachments

gta01-charge-state.patch (424 bytes) - added by andrew.paulsen@… 11 years ago.
Fixes array index error in charge state display (applies after 1182)
chgstate.patch (2.2 KB) - added by mail@… 11 years ago.
Another possible fix for this issue

Change History

Changed 11 years ago by andrew.paulsen@…

Fixes array index error in charge state display (applies after 1182)

Changed 11 years ago by mail@…

Another possible fix for this issue

comment:1 Changed 11 years ago by andrew.paulsen@…

  • attachments.isobsolete changed from 0 to 1

comment:2 Changed 11 years ago by andrew.paulsen@…

Yes, and I agree about the sparse matrix badness. I have tested your patch and
it seems to work correctly so I marked mine as obsolete.

comment:3 Changed 10 years ago by andy

  • Status changed from new to closed
  • Resolution set to fixed

Confirmed Mike's patch applied, closing.

Note: See TracTickets for help on using tickets.