Ticket #1195 (closed defect: wontfix)

Opened 9 years ago

Last modified 8 years ago

gsmd can't pass pressure testing

Reported by: sean_chiang@… Owned by: mickey
Priority: high Milestone:
Component: gsmd Version: 2007.2
Severity: major Keywords:
Cc: mickey@…, buglog@…, erin_yueh@…, chris@…, andy@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: no PatchReviewResult:
Reproducible:

Description

Doing pressure testing, and gsmd would fail under some test case.
I have 4 simple test case, they are:

Q.txt - send AT+CSQ 50 times Both x86 and gta01 are OK
n.txt - send AT+CNUM 50 times Only OK on x86
p.txt - send AT+COPS? 50 times Only OK on x86
sm.txt - send AT+CPMS 71 times Only OK on x86
h.txt - send ATH 100 times Both x86 and gta01 are OK

Fail means gamd will not send at command to GSM modem anymore, which is still
alive.

using libgsmd-tool -m shell < file to do simple pressure testing.

Attachments

pressure-testing.tar.gz (294 bytes) - added by sean_chiang@… 9 years ago.
pressure testing test cases
pressure-testing.tar.2.gz (294 bytes) - added by sean_chiang@… 9 years ago.
pressure testing test cases
Q.txt (300 bytes) - added by sean_chiang@… 9 years ago.
AT+CSQ
n.txt (300 bytes) - added by sean_chiang@… 9 years ago.
AT+CNUM
p.txt (300 bytes) - added by sean_chiang@… 9 years ago.
AT+COPS?
sm.txt (532 bytes) - added by sean_chiang@… 9 years ago.
AT+CPMS
h.txt (300 bytes) - added by sean_chiang@… 9 years ago.
ATH

Change History

comment:1 Changed 9 years ago by sean_chiang@…

  • Status changed from new to assigned

comment:2 Changed 9 years ago by sean_chiang@…

  • Cc mickey@… added

comment:3 Changed 9 years ago by sean_chiang@…

  • Cc chris@… added

Changed 9 years ago by sean_chiang@…

pressure testing test cases

Changed 9 years ago by sean_chiang@…

pressure testing test cases

comment:4 Changed 9 years ago by sean_chiang@…

  • attachments.isobsolete changed from 0 to 1

comment:5 Changed 9 years ago by sean_chiang@…

  • attachments.isobsolete changed from 0 to 1

Changed 9 years ago by sean_chiang@…

AT+CSQ

Changed 9 years ago by sean_chiang@…

AT+CNUM

Changed 9 years ago by sean_chiang@…

AT+COPS?

Changed 9 years ago by sean_chiang@…

AT+CPMS

Changed 9 years ago by sean_chiang@…

ATH

comment:6 Changed 9 years ago by erin_yueh@…

i tried CSQ, COPS, CPMS, these three are fine. But i got cme error 512 from CNUM.

comment:7 Changed 9 years ago by mickey@…

Is it CME or CMS 512? CME 512 is nowhere defined. CMS 512 seems to be a vendor
specific code. I guess that's the Calypso way of saying "not implemented".

comment:8 Changed 9 years ago by sean_chiang@…

I'm sure it is "+CME ERROR 512", and TI had implemented +CNUM indeed. I guess a
special command sequence will make TI GSM modem fall into crazy..

comment:9 Changed 9 years ago by sean_chiang@…

HI!list, This time to send a lots AT+CNUM to do pressure testing. I print what
we read in atcmd_select_cb()

...
Fri Jan 25 15:59:15 2008 <1> atcmd.c:491:atcmd_select_cb() len : 17

Fri Jan 25 15:59:15 2008 <1> atcmd.c:501:atcmd_select_cb() rxbuf :
Fri Jan 25 15:59:15 2008 <1> atcmd.c:503:atcmd_select_cb() 0xd(M)
Fri Jan 25 15:59:15 2008 <1> atcmd.c:503:atcmd_select_cb() 0x0(
@)
Fri Jan 25 15:59:15 2008 <1> atcmd.c:503:atcmd_select_cb() 0xa()
Fri Jan 25 15:59:15 2008 <1> atcmd.c:503:atcmd_select_cb() 0x2b(+)
Fri Jan 25 15:59:15 2008 <1> atcmd.c:503:atcmd_select_cb() 0x43(C)
Fri Jan 25 15:59:15 2008 <1> atcmd.c:503:atcmd_select_cb() 0x4d(M)
Fri Jan 25 15:59:15 2008 <1> atcmd.c:503:atcmd_select_cb() 0x45(E)
Fri Jan 25 15:59:15 2008 <1> atcmd.c:503:atcmd_select_cb() 0x20( )
Fri Jan 25 15:59:15 2008 <1> atcmd.c:503:atcmd_select_cb() 0x45(E)
Fri Jan 25 15:59:15 2008 <1> atcmd.c:503:atcmd_select_cb() 0x52(R)
Fri Jan 25 15:59:15 2008 <1> atcmd.c:503:atcmd_select_cb() 0x52(R)
Fri Jan 25 15:59:15 2008 <1> atcmd.c:503:atcmd_select_cb() 0x4f(O)
Fri Jan 25 15:59:15 2008 <1> atcmd.c:503:atcmd_select_cb() 0x52(R)
Fri Jan 25 15:59:15 2008 <1> atcmd.c:503:atcmd_select_cb() 0x3a(:)
Fri Jan 25 15:59:15 2008 <1> atcmd.c:503:atcmd_select_cb() 0x20( )
Fri Jan 25 15:59:15 2008 <1> atcmd.c:503:atcmd_select_cb() 0x32(2)
Fri Jan 25 15:59:15 2008 <1> atcmd.c:503:atcmd_select_cb() 0x32(2)
Fri Jan 25 15:59:15 2008 <1> atcmd.c:491:atcmd_select_cb() len : -1
...

Now, the problem is there's a terminated character inserted in the return
response. So this response will be ignored and the busy command will always
waiting the response. The n more and more at command will be blocked in pending
queue.

BTW, it only happens on GATA01, I had test it on GTA02, no problem. So I guess
maybe it's because hardware problem or uart driver cause that.

comment:10 Changed 9 years ago by mickey@…

  • Cc andy@… added

Excellent. Sean. We need more of these tests. There may be an undiscovered
problem in the s3c serial driver. cc'ing andy.

comment:11 Changed 9 years ago by andy@…

Hi folks -- one thing to be careful about, I saw crazy behaviour after
powering GSM modem on two A4s including device shutdown. Holding the serial
port open while trying to suspend destroyed resume as well. Then I added a
battery into my device, and although the GSM module remained dead on those
A4s, the crazy behaviour went away. So make sure to try these tests with a
battery in if you didn't already, in case that is anything to do with it.

If there are additional "characters", they could be from some PSU noise maybe
associated with (but evidently not triggering) the device shutdown behaviour I
was seeing?

comment:12 Changed 9 years ago by mickey@…

This needs to be reproduced in MUXing mode. Since gsmd is phasing out, we better
test this with the framework-testing image (due to release early June).

comment:13 Changed 9 years ago by roh

  • Owner changed from sean_chiang@… to sean_chiang

comment:14 Changed 8 years ago by john_lee

  • Owner changed from sean_chiang to mickey
  • HasPatchForReview unset

mickey, shall we close this one and test it on frameworkd?

comment:15 Changed 8 years ago by mickey

  • Status changed from assigned to closed
  • Resolution set to wontfix

Agreed. Further wrt. GSM pressure testing should be done using the frameworkd. Closing this here. gsmd is gone for good.

Note: See TracTickets for help on using tickets.