Ticket #1198 (closed defect: wontfix)

Opened 10 years ago

Last modified 9 years ago

Audio (via headphone jack) doesn't couple well to some line-inputs

Reported by: cwixon@… Owned by: hardware
Priority: high Milestone:
Component: hardware Version: GTA01Bv4
Severity: normal Keywords:
Cc: buglog@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: no PatchReviewResult:
Reproducible:

Description

Most equipment with headphone jacks can be attached to a stereo system with a
suitable adapter. I have found that using a 2.5mm 4-conductor plug to 3.5mm
3-conductor stereo jack adapter to connect the Neo does not work in some
circumstances:

  • it works fine when connected to regular stereo headphones
  • it works fine when connected to some stereo line-in ports
  • it makes loud, percussive, rhythmic noises (several times louder than the

content from the media player, for example) when connected to my car's line-in.

My car's built-in line-in jack is functional with all other equipment I have
tried, including a satellite radio receiver, and various MP3 players and PDAs I
have used in the past. The Neo is the only device that makes these loud noises,
and it happens regardless of whether the engine is running, whether the Neo is
plugged into a power adapter, or whether there is any (intended) sound coming
from the Neo.

As described above, the adapter I have is apparently wired correctly, because it
works with headphones and some other stereo connections. I originally thought
this was noise (of the sort encountered with intermittent/bad amplifier
connections), but continued listening at low volumes, without moving anything,
and the repetitive/rhythmic nature of the noises, indicate that this is
electronic noise of some kind, probably coming from the Neo.

I will try to find a cheap audio isolator (coupling transformer) in the next few
days to see if that makes any difference. And if not, I will make a recording
of the noise and upload it here for further diagnosis.

Change History

comment:1 Changed 10 years ago by cwixon@…

UPDATE.

It works PERFECTLY through a ground-loop isolator, this one from Radio Shack in
particular:

http://www.radioshack.com/product/index.jsp?productId=2062214

Part No. 270-054, US$16.99.

This suggests to me that there's probably a DC offset originating somewhere
(Car->Neo or Neo->Car) that the receiving device doesn't react well to. I don't
have a 'scope so I can't really verify which direction it comes from.

But in either case, it appears the audio output stage of the Neo is non-standard
to some extent, and I'm leaving this bug open for now.

comment:2 Changed 10 years ago by sean_chiang@…

  • Status changed from new to assigned

comment:3 Changed 10 years ago by roh

  • Owner changed from sean_chiang@… to sean_chiang

comment:4 Changed 9 years ago by john_lee

  • Owner changed from sean_chiang to hardware
  • HasPatchForReview unset
  • Component changed from Audio to hardware

Hardware issue. This also seems to be a problem on gta02.

comment:5 Changed 9 years ago by joerg

  • Status changed from assigned to closed
  • Resolution set to wontfix

can not duplicate

Note: See TracTickets for help on using tickets.