Ticket #1209 (closed defect: fixed)

Opened 11 years ago

Last modified 11 years ago

cannot dial emegency call 112 from dialer

Reported by: erin_yueh@… Owned by: chris@…
Priority: high Milestone:
Component: openmoko-dialer Version: 2007.2
Severity: normal Keywords:
Cc: buglog@…, erin_yueh@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible:

Description

we should be able to dial out the emergency call 112, even we don't plug-in SIM
card or we don't camp to the network.

in current design, it will prompt 'Dialer Error: No Network'.

Attachments

112.patch (532 bytes) - added by erin_yueh@… 11 years ago.
dial 112

Change History

comment:1 Changed 11 years ago by chris@…

  • Status changed from new to assigned
  • Summary changed from cannot dial emegency call 112 from dialer to cannot dial emegency call 112 from dialer

Is there any way to identify a number as an emergency number? Some of my old
phones let me try to dial any 3-digit number, others let me dial 112, others
have let me dial 112 and 999 - Should I just let through any 3 digit number and
let the user see what happens, or should I special-case 112?

What about people in non-European countries? (where 112 isn't the emergency
number, as far as I know) A lot of people in my country don't know that 112
resolves to 999 either...

I'll implement this as soon as I know the correct way to handle it.

comment:2 Changed 11 years ago by danielmewes@…

My current mobile (Sony Ericsson K700i) treats 112 (Europe, also part of GSM
standard?) and 911 (USA) specially. Nothing else.
I never heard about that 999 emergency number.

comment:3 Changed 11 years ago by chris@…

999 is the emergency number in the UK - this is exactly my point, how does your
phone know that 911 (or indeed 112) is an emergency number? Are these things
pre-programmed on the phone by vendors?

It could be done via a look-up table on the country code I suppose, via listing
available operators and using the current mapping table of mcc to dc... But
rather than making a huge emergency-number table, I'd like to know how other
phones do this, or if anyone has any further insight into this - also, listing
available operators is a blocking operation (in terms of gsm operations) that
can take upwards of a minute, so this isn't really something we could rely on...

comment:4 Changed 11 years ago by erin_yueh@…

yeah, it's 112!
http://en.wikipedia.org/wiki/Emergency_telephone_number

The telephone number 112 is the international emergency telephone number for GSM
mobile phone networks. Using 112 instead of another emergency number on a GSM
phone may be advantageous, since 112 is recognized by all GSM phones as an
emergency number.

comment:5 Changed 11 years ago by chris@…

Ah, I didn't realise that 112 was the accepted number on GSM, so this makes
things easier.

I've just taken a look at the code though, and dialer shouldn't deny a dial
request unless it isn't on a network at all - it will try if you've been denied,
which I assume will allow emergency numbers to work...

Is dialing an emergency number guaranteed to work if you're not on a network
(including NETREG_DENIED)?

comment:6 Changed 11 years ago by kresp0@…

  • bug_file_loc set to http://en.wikipedia.org/wiki/Emergency_telephone_number#Emergency_numbers

comment:7 Changed 11 years ago by erin_yueh@…

"Is dialing an emergency number guaranteed to work if you're not on a network
(including NETREG_DENIED)?"
yes! i am too late to reply ur comment here.

Changed 11 years ago by erin_yueh@…

dial 112

comment:8 Changed 11 years ago by erin_yueh@…

  • Status changed from assigned to closed
  • Resolution set to fixed

perhaps we can build an emergency number list from
http://en.wikipedia.org/wiki/Emergency_telephone_number#Emergency_numbers later.

Note: See TracTickets for help on using tickets.