Ticket #1224 (closed defect: fixed)

Opened 11 years ago

Last modified 2 years ago

Qemu-neo1973 needs to pass the init script through the preboot-override

Reported by: balrogg@… Owned by: balrogg@…
Priority: high Milestone:
Component: qemu-neo1973 Version: current svn head
Severity: normal Keywords:
Cc: buglog@…, jisakiel@…, nikosverschore@…, john_lee@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible:

Description

Currently we rely on the default u-boot environment being good for flashing by
openmoko/flash.sh and booting. This is not the case in u-boot >= 1.3.0 as we
need a serial console. We can set up the environment in the preboot-override
script or we can pass the whole serie of commands that we use for flashing, as a
preboot-override script. Let's do the former for the moment.

Change History

comment:1 Changed 11 years ago by balrogg@…

  • Status changed from new to assigned

comment:2 Changed 11 years ago by balrogg@…

  • Cc john_lee@… added
  • Status changed from assigned to closed
  • Resolution set to fixed

Done in r4037, in a slightly hacky way but good enough for using >= u-boot-1.3.0
for flashing qemu-neo1973 and make it more immune to future u-boot changes.

comment:3 Changed 11 years ago by nikosverschore@…

  • Status changed from closed to reopened
  • Resolution fixed deleted

I think it isn't fixed yet:

rm -f images/openmoko/env

[ -d stamps ]
mkdir stamps

touch stamps/images
( cd build/qemu && openmoko/flash.sh ../../images/openmoko )
/usr/bin/pngtopnm
/usr/bin/ppmtorgb3
make[1]: Entering directory `/home/black/progie/openmoko/build/qemu/openmoko'
make[1]: `splash.gz' is up to date.
make[1]: Leaving directory `/home/black/progie/openmoko/build/qemu/openmoko'
Using 'uImage-2.6.24+svnr4184-r4165-r3-neo1973.bin' as the kernel image.
Using
'OpenMoko?-openmoko-devel-image-glibc-ipk-P1-Snapshot-20080313-fic-gta01.rootfs.jffs2'
as the root filesystem image.
Using
'u-boot-gta01bv4-1.3.1+git10bbb38a402a2faf18858c451bcdc63d45888e6e+svn4118-r3.bin'
as bootloader.
make[1]: Entering directory `/home/black/progie/openmoko/build/qemu/openmoko'
# Making an empty/erased flash image. Need a correct echo behavior.
echo -en
0377
0377
0377
0377
0377
0377
0377
0377 > .8b
cat .8b .8b > .16b # OOB is 16 bytes
cat .16b .16b .16b .16b .16b .16b .16b .16b > .512b
cat .16b .16b .16b .16b .16b .16b .16b .16b >> .512b
cat .16b .16b .16b .16b .16b .16b .16b .16b >> .512b
cat .16b .16b .16b .16b .16b .16b .16b .16b >> .512b
cat .512b .16b > .sec # A sector is 512 bytes of data + OOB
cat .sec .sec .sec .sec .sec .sec .sec .sec > .8sec
cat .8sec .8sec .8sec .8sec .8sec .8sec .8sec .8sec > .64sec
cat .64sec .64sec .64sec .64sec .64sec .64sec .64sec .64sec > .512sec
cat .512sec .512sec .512sec .512sec > .2ksec
cat .2ksec .2ksec .2ksec .2ksec .2ksec .2ksec .2ksec .2ksec > .16ksec
# Neo NAND is 128k sectors big
cat .16ksec .16ksec .16ksec .16ksec .16ksec .16ksec .16ksec .16ksec >
openmoko-flash.base
rm -rf .8b .16b .512b .sec .8sec .64sec .512sec .2ksec .16ksec
make[1]: Leaving directory `/home/black/progie/openmoko/build/qemu/openmoko'
Please wait, programming the NAND flash...
neo_gsm_switch: GSM disabled.

U-Boot 1.3.1+git10bbb38a402a2faf18858c451bcdc63d45888e6e+svn4118 (Feb 29 2008 -
04:36:26)

I2C: ready
DRAM: 128 MB
NAND: Bad block table not found for chip 0
Bad block table not found for chip 0
64 MiB
Video: 640x480x8 31kHz 59Hz
USB: S3C2410 USB Deviced
mtdparts variable not set, see 'help mtdparts'
mtdparts variable not set, see 'help mtdparts'
mtdparts variable not set, see 'help mtdparts'
mtdparts variable not set, see 'help mtdparts'
mtdparts variable not set, see 'help mtdparts'
pcf_write: charging in Qualification Mode.
pcf_write: charge voltage 4.20V.
neo_lcd_rst_switch: LCD reset.
jbt6k74_command: Display on.
neo_vib_switch: Buzz, buzz.
neo_vib_switch: Vibrator stopped.
neo_bl_switch: LCD Backlight now on.
qemu: fatal: Trying to execute code outside RAM or ROM at 0x00000000

R00=33f1fc04 R01=ffffffff R02=00000000 R03=34008524
R04=00000000 R05=00000000 R06=00000000 R07=00000000
R08=33f17fdc R09=00000000 R10=00000000 R11=00000000
R12=0000004a R13=33f14d84 R14=00000000 R15=00000000
PSR=60000153 -ZC- A svc32
s00=00000000( 0) s01=00000000( 0) d00=0000000000000000( 0)
s02=00000000( 0) s03=00000000( 0) d01=0000000000000000( 0)
s04=00000000( 0) s05=00000000( 0) d02=0000000000000000( 0)
s06=00000000( 0) s07=00000000( 0) d03=0000000000000000( 0)
s08=00000000( 0) s09=00000000( 0) d04=0000000000000000( 0)
s10=00000000( 0) s11=00000000( 0) d05=0000000000000000( 0)
s12=00000000( 0) s13=00000000( 0) d06=0000000000000000( 0)
s14=00000000( 0) s15=00000000( 0) d07=0000000000000000( 0)
s16=00000000( 0) s17=00000000( 0) d08=0000000000000000( 0)
s18=00000000( 0) s19=00000000( 0) d09=0000000000000000( 0)
s20=00000000( 0) s21=00000000( 0) d10=0000000000000000( 0)
s22=00000000( 0) s23=00000000( 0) d11=0000000000000000( 0)
s24=00000000( 0) s25=00000000( 0) d12=0000000000000000( 0)
s26=00000000( 0) s27=00000000( 0) d13=0000000000000000( 0)
s28=00000000( 0) s29=00000000( 0) d14=0000000000000000( 0)
s30=00000000( 0) s31=00000000( 0) d15=0000000000000000( 0)
FPSCR: 00000000
openmoko/flash.sh: line 91: 21901 Aborted (core dumped) $qemu
-mtdblock "$script_dir/$flash_base" -kernel "$script_dir/$1" -serial stdio
-nographic -usb -monitor null 0<&0

U-boot failed to finish writing in 300 seconds, giving up.

openmoko/flash.sh: line 96: 21902 Terminated ( sleep $2; kill $pid;
sleep 1; kill -KILL $pid )
openmoko/flash.sh: line 96: kill: (-21838) - No such process
make: * [flash-qemu-official] Error 255

comment:4 Changed 11 years ago by balrogg@…

  • Status changed from reopened to closed
  • Resolution set to fixed

Same as #937, bug unrelated to qemu.

comment:5 Changed 11 years ago by jisakiel@…

  • Status changed from closed to reopened
  • Resolution fixed deleted

Same bug as mentioned on #2 on a cleaned source updated as of 25 March, using
Mokomakefile on Hardy amd64 with gcc-3.4.6 . I reopen the bug...

comment:6 Changed 11 years ago by balrogg@…

  • Cc jisakiel@… added

comment:7 Changed 11 years ago by balrogg@…

  • Status changed from reopened to closed
  • Cc nikosverschore@… added
  • Resolution set to fixed

Marking the Qemu bug back as fixed, since it is fixed.

What you're seeing is not a bug. A bug in an emulator is when it behaves
different from the real hardware. I say this u-boot will kill your physical
Neo1973, so it also kills qemu, that's a correct behaviour for qemu.

Now you may submit a bug against u-boot but it should be fixed (see
openmoko-kernel list archive for details), I'm not sure.

comment:8 Changed 2 years ago by JustDox

Generic Amoxicilina Website On Line <a href=http://kama1.xyz/buy-kamagra-online.php>Buy Kamagra Online</a> Amoxicillin Pre Med Dental Cialis One Day Quanto Costa <a href=http://viag1.xyz/low-price-viagra.php>Low Price Viagra</a> Amoxicillin For Upper Resp Infections Viagra Et Le Coeur <a href=http://cial5mg.xyz/cheap-cialis-online.php>Cheap Cialis Online</a> Cialis Levitra Ou Viagra isotretinoin cheap internet with free shipping over night <a href=http://kama1.xyz/kamagra-pills.php>Kamagra Pills</a> Where To Buy Cialis Alternative Fur Levitra <a href=http://viag1.xyz/cheap-viagra-generic.php>Cheap Viagra Generic</a> No Perscription Viagra Cialis Generique Avis <a href=http://kama1.xyz/cheap-kamagra.php>Cheap Kamagra</a> Vente Viagra Livraison Gratuite How To Order Flagyl In Hampton <a href=http://cial1.xyz/cialis-online.php>Cialis Online</a> Cephalexin Prescribed For Cialis Durata Erezione <a href=http://kama1.xyz/buy-kamagra-usa.php>Buy Kamagra Usa</a> Worldwide Clobetasol Lichen Planus Cod Internet Store Express Delivery Newcastle Meningitis Mite Amoxicillin <a href=http://inderal.ccrpdc.com/buy-propranolol-40mg.php>Buy Propranolol 40mg</a> Is Keflex A Sulfa Drug Mail Order Celebrex <a href=http://zol1.xyz/fast-delivery-zoloft.php>Fast Delivery Zoloft</a> Viagra Pillola Rossa Fish <a href=http://viag1.xyz/generic-viagra-pills.php>Generic Viagra Pills</a> Lamisil Tablets At Ebay Cheapest Genaroc Viagra <a href=http://doxycycline.ccrpdc.com/where-to-order-vibramycin.php>Where To Order Vibramycin</a> Prezzo Di Levitra Cialis Ebay <a href=http://viag1.xyz/order-viagra-online.php>Order Viagra Online</a> Cheap Antabuse Disulfiram Cialis 20 Mg Tadalafil Commander <a href=http://zol1.xyz/buy-cheap-zoloft-site.php>Buy Cheap Zoloft Site</a> discount on line fedex shipping isotretinoin 10mg medication direct Cialis Super Kamagra <a href=http://cytotec.ccrpdc.com>Buy Cytotec</a> Can I Take Expired Amoxicillin Pills Cialis Authentique Prix <a href=http://kama1.xyz/online-pharmacy-kamagra.php>Online Pharmacy Kamagra</a> Achat Kamagra Caen Viraga Sales <a href=http://kama1.xyz/where-can-i-buy-kamagra.php>Where Can I Buy Kamagra</a> 1742 Buy Tinidazole 500mg Alert <a href=http://cial5mg.xyz/cialis-40mg.php>Cialis 40mg</a> Viagra Price Online Cytotec Et Maladie <a href=http://cial1.xyz/cialis-online.php>Cialis Online</a> Kamagra Preise How To Buy Cialis From Canada <a href=http://cial5mg.xyz/prices-cialis.php>Prices Cialis</a> Decongestant Amoxicillin Generic Viagra 100 Mg <a href=http://cial5mg.xyz/generic-cialis-pricing.php>Generic Cialis Pricing</a> Tabletten Viagra Kaufen Generic Stendra <a href=http://kama1.xyz/kamagra-online-cheap.php>Kamagra Online Cheap</a> Real Shipped Ups Amoxicilina Free Shipping Discount Shop Uroxatral Or Propecia <a href=http://cial5mg.xyz/shop-cialis-online.php>Shop Cialis Online</a> Levitra En La Farmacia Cialis Im Internet Kaufen Erfahrungen <a href=http://cial5mg.xyz/buy-cialis-online.php>Buy Cialis Online</a> Buy Nexium In Canada Sildalis <a href=http://viag1.xyz/buy-generic-viagra.php>Buy Generic Viagra</a> Cialis Online Kaufen Test Viagra Wirkungsdauer <a href=http://cial1.xyz/buy-tadalafil-online.php>Buy Tadalafil Online</a> Where To Buy Doxycycline For Dogs Cialis En Generique <a href=http://antabuse.ccrpdc.com/antabuse-order.php>Antabuse Order</a> Prescribing Information For Amoxicillin Purchase Celebrex No Prescription <a href=http://cial1.xyz/buy-tadalafil-online.php>Buy Tadalafil Online</a> Buying Free Shipping Isotretinoin Isotrex Best Website

Note: See TracTickets for help on using tickets.