Ticket #1226 (closed defect: fixed)

Opened 9 years ago

Last modified 3 days ago

Support USSD messages, e.g. for "remaining airtime" checks

Reported by: mail@… Owned by: erin_yueh
Priority: high Milestone:
Component: gsmd Version: current svn head
Severity: normal Keywords:
Cc: buglog@…, reddog@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible:

Description

gsmd and other related applications should support USSD (Unstructured
Supplementary Service Data) messages from the carrier. This protocol is used
with some prepaid plans to check the remaining balance. For example, with Fido
Prepaid (Canada) I dial "*225" and get a USSD response indicating the answer:

AT+CUSD=1
OK
ATD*225;
OK

%CPRI: 1,2
+CUSD: 0,"Your balance is $55.15, expiring at 00:01am 15022008 (DDMMYYYY).
Refill before this date to keep your unused balance. Thank you.",15

ATH
OK

These messages may also appear when a regular call is made, e.g.:

ATD604xxxxxxx;

K

%CPRI: 1,2
+CUSD: 0,"Reminder: Airtime expires soon. Please refill to avoid losing airtime5

%CSQ: 21, 99, 2

There are probably other USSD-related functions that should be supported at some
point, but just passing these messages through to the user's GUI would be a good
start (and would be required for a "consumer-ready" phone).

Change History

comment:1 Changed 9 years ago by tick@…

  • Owner changed from tick@… to erin_yueh@…

comment:2 Changed 9 years ago by erin_yueh@…

  • Status changed from new to assigned

comment:3 Changed 9 years ago by roh@…

  • Cc reddog@… added

comment:4 Changed 9 years ago by roh@…

* Bug 1348 has been marked as a duplicate of this bug. *

comment:5 Changed 9 years ago by roh

  • Owner changed from erin_yueh@… to erin_yueh

comment:6 Changed 9 years ago by zecke

Just for the record: Qtopia does display +CUSD messages, or did in the past.

comment:7 Changed 9 years ago by tick

  • Status changed from assigned to closed
  • Resolution set to fixed

I don't think it's a qtopia issue.
And I think it's already solved.

comment:8 Changed 3 days ago by JustDox

Cialis Efectos Secundarios <a href=http://antabuse.ccrpdc.com/antabuse-generic-name.php>Antabuse Generic Name</a> Online Pyridium Mail Order Glendale Cialis Generique Pas Cher En France <a href=http://zol1.xyz/zoloft-50mg.php>Zoloft 50mg</a> Bentyl Formulex Canada Website Next Day Without Perscription Comment Durer Plus Longtemps Cours <a href=http://cial5mg.xyz/generic-cialis-usa.php>Generic Cialis Usa</a> Viagra Free Trial Prix Medicament Cytotec <a href=http://cial1.xyz/can-i-buy-cialis-online.php>Can I Buy Cialis Online</a> Zithromax For Rabbits Amoxicillin Dosage Rat <a href=http://zol1.xyz/zoloft-free-offer.php>Zoloft Free Offer</a> Viagra Kaufen In Deutschland Canadian Pharmaci <a href=http://zoloft.ccrpdc.com/buy-zoloft-cheap.php>Buy Zoloft Cheap</a> Generic Secure Amoxicilina For Sale Internet With Free Shipping Usa Viagra Online Pharmacy <a href=http://lasix.ccrpdc.com/lasix-online-prices.php>Lasix Online Prices</a> Levitra Et Pamplemousse Kamagra Us <a href=http://viag1.xyz/real-viagra-online.php>Real Viagra Online</a> Cialis Laboratoire Lilly Viagra 100mg Cost <a href=http://kama1.xyz/buy-cheap-generic-kamagra.php>Buy Cheap Generic Kamagra</a> Amoxicillin Dosing In Infants Cialis Livraison Rapide <a href=http://cial1.xyz/cialis-buy-online.php>Cialis Buy Online</a> Adverse Effect Of Amoxicillin For Elderly Zithromax Can You Drink <a href=http://zol1.xyz>Buy Zoloft</a> Buy Buspirone Online U.K Fedex Shipping Progesterone Mail Order <a href=http://cial1.xyz/tadalafil-online.php>Tadalafil Online</a> Whexenical No Prior Prescritption Achat Kamagra Paris <a href=http://strattera.ccrpdc.com/strattera-cost.php>Strattera Cost</a> Propranolol Online Delivered In Usa Buy Propecia Online Usa <a href=http://kama1.xyz/cheap-kamagra-pill.php>Cheap Kamagra Pill</a> Generique Cialis Generique 5 Mg Cialis Online <a href=http://zol1.xyz/implicane.php>Implicane</a> Finasteride 10mg Where To Buy Order Amoxil <a href=http://zol1.xyz/zoloft-on-line.php>Zoloft On Line</a> Amoxicillin Capsules Images Uso Viagra Cialis Levitra <a href=http://zol1.xyz/zoloft-implicane.php>Zoloft Implicane</a> Cialis Sin Receta Foro Is There A Way To Get Avanafil Cheaper <a href=http://cial1.xyz/cialis-20mg-price.php>Cialis 20mg Price</a> Doxycycline Order Online Canada

Note: See TracTickets for help on using tickets.