Ticket #1232 (closed defect: fixed)

Opened 11 years ago

Last modified 10 years ago

PIN authentication does not work

Reported by: tilman.klar@… Owned by: tick@…
Priority: high Milestone:
Component: gsmd Version: current svn head
Severity: major Keywords:
Cc: buglog@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible:

Description

When booting the Neo1973 using my T-Mobile SIM card using OM2007.2, no PIN
dialog shows up and I'm unable to connect to the GSM network. So I tried using
the latest kernel/rootfs from
http://buildhost.openmoko.org/daily/neo1973/deploy/glibc/images/neo1973, which
actually gives me the PIN dialog. However, when keying in the correct PIN, the
phone just keeps asking for it again. When looking at the logfile, one can see
what happens in lines 672 and 697. I closed the dialog by pressing 'back' and
waited a little, since I saw the "AT+CPIN?" command scrolling by. After that, I
was able to key in my PIN using the following procedure (USB-Networking):
---cut---
root@fic-gta01:~$ libgsmd-tool -m atcmd
libgsm-tool - (C) 2006-2007 by Harald Welte and OpenMoko?, Inc.
This program is Free Software and has ABSOLUTELY NO WARRANTY

AT+CPIN="...."
STR=`AT+CPIN="...."'
RSTR=`OK'
---cut---

I registered to the network using libgsmd-tool and now the phone works without a
hitch. Although I only have a limited knowledge concerning this GSM issue, from
my opinion it would be best to prepend an 'AT+CPIN?' every time the PIN dialog
sends an 'AT+CPIN="...."', would it not?

I'll attach the logfile and start playing with my new phone now. It sure is a
great gadget.

Attachments

gsm.log (158.7 KB) - added by tilman.klar@… 11 years ago.
gsm.log which reflects the reported PIN behavior
gsm.2.log (74.4 KB) - added by tilman.klar@… 11 years ago.
gsm.log when proceeding as explained in comment #2

Change History

Changed 11 years ago by tilman.klar@…

gsm.log which reflects the reported PIN behavior

comment:1 Changed 11 years ago by tilman.klar@…

Actually, it seems like an AT+CPIN? does not suffice to work around this issue.
I found an alternative, though:
1) Boot up the phone
2) Wait for the pin dialog, but don't key in any pin
3) Connect to the phone using USB networking
4) Spawn a gsmd-shell using "libgsmd-tool -m shell" and query the pin status
using "gp"
5) Key in the PIN using the dialog
6) The phone establishes the connection to the network

Will also attach the log for this.

Changed 11 years ago by tilman.klar@…

gsm.log when proceeding as explained in comment #2

comment:2 Changed 11 years ago by Graham.Williams@…

The "fix" here did not work for me. I did find though that if I cancel the PIN
request on startup, then connect to the Neo from a host through USB, then do the
manual entry as suggested:

root@fic-gta01:~$ libgsmd-tool -m atcmd
libgsm-tool - (C) 2006-2007 by Harald Welte and OpenMoko?, Inc.
This program is Free Software and has ABSOLUTELY NO WARRANTY

AT+CPIN="...."
STR=`AT+CPIN="...."'
RSTR=`OK'
---cut---

Then on the GSM icon, select "Autoregister with Network," I'm up and running again.

comment:3 Changed 10 years ago by erin_yueh@…

it's probably atcmd buffer length problem, please update gsmd version > svnr4066.

or you could try to use this gsmd version first:

  1. get the tar file from

http://people.openmoko.org/erin_yueh/gsmd_r4084_fromErin.tar.gz

  1. from local PC

#scp gsmd_r4084_fromErin.tar.gz root@192.168.0.202:/

  1. from NEO

# ssh root@192.168.0.202
# killall gsmd
# tar zxvf gsmd_r4084_fromErin.tar.gz

(it will replace with all old gsmd lib files)

# /etc/init.d/gsmd restart

(restart gsmd daemon)

  1. now, hope you can enter your PIN code


comment:4 Changed 10 years ago by tilman.klar@…

Erin,

the tarball you provided in #5 works like a charm on my Neo. After I key in the
PIN, the device auto-registers with the correct network (T-Mobile D). Thanks for
the help. Graham, could you try if this also does the trick for you?

comment:5 Changed 10 years ago by Graham.Williams@…

Thanks Erin, Tilman.

The fix from Erin in #5 also works for me. Tested on the 20080219 image (which
still has the problem if the fix is not applied).

comment:6 Changed 10 years ago by tick@…

  • Status changed from new to closed
  • Resolution set to fixed

I think Erin has fixed this.

Note: See TracTickets for help on using tickets.