Ticket #1238 (closed defect: community)

Opened 9 years ago

Last modified 9 years ago

SIM card contacts not displayed

Reported by: will@… Owned by: olv@…
Priority: highest Milestone:
Component: Applications & Dependencies Version: unspecified
Severity: normal Keywords: OpenMoko
Cc: devel@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: no PatchReviewResult:
Reproducible:

Description

Contents of SIM card contacts are not displayed in Contacts

Attachments

openmoko-contacts-pb-import.patch (22.2 KB) - added by olv@… 9 years ago.
make openmoko-contacts import phonebook
a.patch (25.8 KB) - added by olv@… 9 years ago.
make phonekit sync phonebook on startup
queryAntennaStatus.patch (2.8 KB) - added by erin_yueh@… 9 years ago.
query antenna status

Change History

comment:1 Changed 9 years ago by will@…

  • Keywords OpenMoko added; Neo1973 Hardware removed
  • product changed from Neo1973 Hardware to OpenMoko
  • Component changed from GSM Modem to Applications & Dependencies
  • op_sys changed from MacOS X to other

comment:2 Changed 9 years ago by will@…

  • rep_platform changed from Macintosh to Other

comment:3 Changed 9 years ago by will@…

  • Priority changed from high to highest

comment:4 Changed 9 years ago by erin_yueh@…

  • Cc olv@… added

olv, i assign this bug to you! thanks a lot! if you need me verify your code,
please let me know.

comment:5 Changed 9 years ago by olv@…

  • Owner changed from erin_yueh@… to olv@…

Changed 9 years ago by olv@…

make openmoko-contacts import phonebook

comment:6 Changed 9 years ago by olv@…

  • attachments.isobsolete changed from 0 to 1

comment:7 Changed 9 years ago by olv@…

  • Cc chris@… added

comment:8 Changed 9 years ago by chris@…

Patch looks good, except if you make a change to an imported pb contact, you'll
end up with two contacts when you restart phone-kit? Also, if you delete the
contact, it'll just be re-imported when phone-kit is restarted? I might have
misread the patch though, please correct me if I'm wrong :)

comment:9 Changed 9 years ago by olv@…

It checks the names to avoid duplications. So if you make change to the name or
delete an contact, it will be imported again next time phonekit starts.

Because of the limitations of phonebook comparing to EBook, phonebook
manipulations should not be transparent. That is, we do not propagate changes
to EBook back to phonebook automatically. Instead, other than talking to EBook,
openmoko-contacts should also talk to a not-existing-yet dbus interface for
phonebook manipulations. E.g., when moving the storage of certain contact to
the phonebook, openmoko-contacts should pop up a dialog warning the user that
some infomation might be lost; or, before entering information that is not able
to be stored in the phonebook, a dialog should pop up and asks if the user want
to move the storage to the phone.

Therefore, I prefer not to change phonebook in a way that is not visible by the
users.

comment:10 Changed 9 years ago by erin_yueh@…

  • Cc erin_yueh@… added

comment:11 Changed 9 years ago by erin_yueh@…

there is a problem from retrieving all entries from Phonebook, coz we have to
confirm the modem status before sending any AT commands to modem. i added a
function in gsmd to query the current antenna status.

Changed 9 years ago by erin_yueh@…

query antenna status

comment:12 Changed 9 years ago by olv@…

  • Status changed from new to closed
  • Resolution set to fixed

a slightly modified version is committed as svn r4176, r4178

comment:13 in reply to: ↑ description Changed 9 years ago by montgoss

  • Cc devel@… added; buglog@…, erin_yueh@…, chris@…, olv@… removed
  • Status changed from closed to reopened
  • Resolution fixed deleted

Replying to 1238:

Contents of SIM card contacts are not displayed in Contacts

This sounds like the bug I'm currently having. I know this was closed a long time ago, so perhaps it's a separate issue that has the same symptoms...

comment:14 Changed 9 years ago by LMC

I have a similar issue; there is also a new defect ticket:1639 on this.

comment:15 Changed 9 years ago by montgoss

These are two separate issues. This bug is where there are NO contacts displayed.
1639 is what happens on the newest daily builds where only some contacts off the SIM are displayed.

comment:16 Changed 9 years ago by john_lee

  • Status changed from reopened to closed
  • HasPatchForReview unset
  • Resolution set to community

@montgoss:

On 2008/7/18 there is no om2008.8 yet so I assume this is still an om2007 bug. Since we won't maintain it anymore, I will close it as 'community'.

Note: See TracTickets for help on using tickets.