Ticket #1262 (closed defect: fixed)

Opened 11 years ago

Last modified 11 years ago

X dies just before loading the desktop

Reported by: ahvenas@… Owned by: sean_chiang@…
Priority: high Milestone:
Component: Core System Version: GTA01Bv4
Severity: normal Keywords:
Cc: buglog@…, john_lee@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible:

Description

This bug happens in about 1 out 3 bootups. Rootfs flashed with
Snapshot-20080306-fic-gta01 and kernel with 2.6.24+svnr4154-r4165-r3-neo1973.
Current solution is to login through SSH and start xserver-nodm manually, it has
never crashed there so far.

Attachments

x.log (10.5 KB) - added by ahvenas@… 11 years ago.
X logfile for Snapshot-20080321

Change History

Changed 11 years ago by ahvenas@…

X logfile for Snapshot-20080321

comment:1 Changed 11 years ago by scaredycat@…

A few lines from my x.log (booted ok)

sh: /usr/bin/cpp: not found
(neod:1368): DEBUG: '/dev/input/event0' open OK, fd = '5'
(neod:1368): DEBUG: '/dev/input/event1' open OK, fd = '6'
(neod:1368): DEBUG: '/dev/input/event2' open OK, fd = '7'
(neod:1368): DEBUG: opened 3 input nodes.
(neod:1368): DEBUG: added fd 5 to list of watchers
(neod:1368): DEBUG: added fd 6 to list of watchers
(neod:1368): DEBUG: added fd 7 to list of watchers
(neod:1368): DEBUG: mainmenu powersave reset
(neod:1368): DEBUG: setting debug output to false
(neod:1368): DEBUG: mainmenu powersave reset
(neod:1368): DEBUG: requested to set display brightness 100
(neod:1368): DEBUG: backlight_node_dir = gta01-bl
(neod:1368): DEBUG: detected backlight in sysfs as
'/sys/class/backlight/gta01-bl/brightness'
(neod:1368): DEBUG: scanned maximum brightness for
'/sys/class/backlight/gta01-bl/brightness' = '5156'
(neod:1368): DEBUG: writing '5156' to '/sys/class/backlight/gta01-bl/brightness'
(neod:1368): DEBUG: panel mainmenu sound init
(neod:1368): DEBUG: mainmenu sound state callback. state = 1
(neod:1368): DEBUG: sound init ok. threaded mainloop started
(neod:1368): DEBUG: mainmenu sound state callback. state = 2
(neod:1368): DEBUG: mainmenu sound state callback. state = 3
(neod:1368): DEBUG: mainmenu sound state callback. state = 4

looks like a sound init issue?

comment:2 Changed 11 years ago by john_lee@…

  • Cc john_lee@… added

comment:3 Changed 11 years ago by john_lee@…

/tmp/x.log:
_XSERVTransSocketOpenCOTSServer: Unable to open socket for inet6
_XSERVTransOpen: transport open failed for inet6/om-gta02:0
_XSERVTransMakeAllCOTSServerListeners: failed to open listener for inet6
(II) verbosity set to 5
Using GLAMO 3362 card
(II) Screen: 16/16 depth/bpp
(II) vram size:4194304, onscreen vram size:614400, offscreen vram size:3579904
(II) initialising offscreen pixmaps
Extended Input Devices not yet supported. Impelement it at line 637 in kinput.c
D-BUS per-session daemon address is:
unix:abstract=/tmp/dbus-wGVXzaXLaw,guid=13c819271432518f1b001f7447fbfb1a
[settings daemon] Forking. run with -n to prevent fork
(neod:2237): DEBUG: '/dev/input/event0' open OK, fd = '4'
(neod:2237): DEBUG: '/dev/input/event1' open OK, fd = '5'
(neod:2237): DEBUG: '/dev/input/event2' open OK, fd = '6'
(neod:2237): DEBUG: '/dev/input/event3' open OK, fd = '7'
(neod:2237): DEBUG: '/dev/input/event4' open OK, fd = '8'
(neod:2237): DEBUG: opened 5 input nodes.
(neod:2237): DEBUG: added fd 4 to list of watchers
(neod:2237): DEBUG: added fd 5 to list of watchers
(neod:2237): DEBUG: added fd 6 to list of watchers
(neod:2237): DEBUG: added fd 7 to list of watchers
(neod:2237): DEBUG: added fd 8 to list of watchers
sh: /usr/bin/cpp: not found
(neod:2237): DEBUG: mainmenu powersave reset
(neod:2237): DEBUG: setting debug output to false
(neod:2237): DEBUG: mainmenu powersave reset
(neod:2237): DEBUG: requested to set display brightness 100
(neod:2237): DEBUG: backlight_node_dir = pcf50633-bl
(neod:2237): DEBUG: detected backlight in sysfs as
'/sys/class/backlight/pcf50633-bl/brightness'
(neod:2237): DEBUG: scanned maximum brightness for
'/sys/class/backlight/pcf50633-bl/brightness' = '63'
(neod:2237): DEBUG: writing '63' to '/sys/class/backlight/pcf50633-bl/brightness'
(neod:2237): DEBUG: panel mainmenu sound init
(neod:2237): DEBUG: mainmenu sound state callback. state = 1

(process:2237): DEBUG (recursed): sound init ok. threaded mainloop started
aborting...
run-parts: /etc/X11/Xsession.d/90xXWindowManager exited with return code 1006

waiting for X server to shut down FreeFontPath?: FPE "built-ins" refcount is 2,
should be 1; fixing.

comment:4 Changed 11 years ago by olv@…

  • Status changed from new to closed
  • Resolution set to fixed

fixed in svn r4351.

Note: See TracTickets for help on using tickets.