Ticket #1268 (closed defect: worksforme)

Opened 11 years ago

Last modified 11 years ago

Build fails because of glib & libogg dependencies

Reported by: santiago.aguiar@… Owned by: mickey@…
Priority: high Milestone:
Component: OE bitbake recipes / build system Version: current svn head
Severity: blocker Keywords:
Cc: buglog@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:


I started working with openmoko and openembedded a couple of days ago, building
it for a QTek blueangel PDA.

I checked out openembedded trunk version and performed a build from there. I had
the following errors:

| ERROR: Cannot satisfy the following dependencies for task-openmoko-pim:
| libogg0 (>= 1.1.3)

And a similar one for task-openmoko-ui asking for glib >= 2.15.6.

I added:

PREFERRED_VERSION_glib-2.0 = "2.15.6"
PREFERRED_VERSION_libogg = "1.1.3"

to conf/distro/include/preferred-om-2008-versions.inc and the image was
correctly built (but not yet tested on the target).

I need confirmation that this is actually a bug, I'm not yet confident with the
codebase to be sure that I didn't messed up or followed an incorrect build
processes (or even if this is an openembedded problem instead of an openmoko one!).

Change History

comment:1 Changed 11 years ago by santiago.aguiar@…

This patch solved the problem for me.

# old_revision [be65002bdf2cc86e74c6837a77000ad7f649e754]
# patch "conf/distro/include/preferred-om-2008-versions.inc"
# from [45c4fabe80b7601dd86c45ad8f64a6773594d4e7]
# to [03aa6c652327fdca1d505eb10c4fdcc8147bbe24]
--- conf/distro/include/preferred-om-2008-versions.inc
+++ conf/distro/include/preferred-om-2008-versions.inc
@@ -12,4 +12,5 @@ PREFERRED_VERSION_vte = "0.16.9"

PREFERRED_VERSION_pulseaudio = "0.9.9"
PREFERRED_VERSION_vte = "0.16.9"

+PREFERRED_VERSION_glib-2.0 = "2.15.6"
+PREFERRED_VERSION_libogg = "1.1.3"

comment:2 Changed 11 years ago by john_lee@…

  • Status changed from new to closed
  • Resolution set to worksforme

the current pair of glib-2.0 and libogg is

PREFERRED_VERSION_glib-2.0 ?= "2.14.1"
PREFERRED_VERSION_libogg ?= "1.1"

in angstrom-2007-for-openmoko-versions.inc

and I cannot find the libogg >= 1.1.3 dependency you mentioned in
org.openmoko.dev branch. could you update the branch and check your local.conf.

If the problem still exists please kindly reopen.

Note: See TracTickets for help on using tickets.