Ticket #1280 (closed defect: fixed)

Opened 10 years ago

Last modified 9 years ago

qvga themes/icons do not build due to sed problem

Reported by: lukas.gorris@… Owned by: openmoko-devel
Priority: high Milestone:
Component: Theming - Gtk+ Version: unspecified
Severity: normal Keywords:
Cc: buglog@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: no PatchReviewResult:
Reproducible:

Description

qvga themes/icons do not build due to unmatched dependency librsvg-native

ERROR: Required build target 'openmoko-icon-theme-standard2-qvga' has no
buildable providers.
Missing or unbuildable dependency chain was:
['openmoko-icon-theme-standard2-qvga', 'librsvg-native']

There is a librsvg but no librsvg-native.

Change History

comment:1 Changed 10 years ago by lukas.gorris@…

somebody told me to add
ASSUME_PROVIDED += "librsvg-native"
to my local.conf which made the librsvg-native error disappear. now I'm facing
the following do_configure problem with openmoko-icon-theme-standard2-qvga

org.openembedded.dev/tmp/work/all-angstrom-linux-gnueabi/openmoko-icon-theme-standard2-qvga-0.1.0+svnr3247-r2/temp/log.do_configure.8985
sed: can't read {32x32,48x48}/Makefile.am: No such file or directory

comment:2 Changed 10 years ago by mickey@…

  • Summary changed from qvga themes/icons do not build due to unmatched dependencies to qvga themes/icons do not build due to sed problem

Changing the name, since this is by design. You are supposed to ASSUME_PROVIDED
this since we don't have it in OE. Yes, it's a documentation issue, but then
again, the qvga theme is rarely requested anyways.

As for the latter problem, which computer/distro are you building on?

comment:3 Changed 10 years ago by thomas@…

I've added 22x22 icons to openmoko-standard icon theme, so a special qvga
version of the icon theme should no longer be required.

comment:4 Changed 9 years ago by roh

  • Owner changed from openmoko-devel@… to openmoko-devel

comment:5 Changed 9 years ago by john_lee

  • Status changed from new to closed
  • HasPatchForReview unset
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.