Ticket #1282 (closed defect: community)

Opened 9 years ago

Last modified 9 years ago

Remove rotate display option

Reported by: will@… Owned by: erin_yueh
Priority: highest Milestone:
Component: Applications & Dependencies Version: unspecified
Severity: normal Keywords:
Cc: buglog@…, nomeata Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: no PatchReviewResult:
Reproducible:

Description

Remove this feature out of the option menu.

Attachments

removeAUXButton.patch (760 bytes) - added by erin_yueh@… 9 years ago.
remove AUX button key event
removeSWAPOrientationforGTA02.patch (1018 bytes) - added by erin_yueh@… 9 years ago.
remove SWAP orientation button from option menu
disableSWAPOrientationforGTA02.patch (847 bytes) - added by erin_yueh@… 9 years ago.
disable SWAP orientation button from option menu

Change History

comment:1 Changed 9 years ago by scaredycat@…

Is there any reason this is being removed? It is quite useful.

comment:2 Changed 9 years ago by erin_yueh@…

  • Status changed from new to assigned

Changed 9 years ago by erin_yueh@…

remove AUX button key event

comment:3 Changed 9 years ago by erin_yueh@…

  • Status changed from assigned to closed
  • Resolution set to fixed

I am sorry about that! we decide to remove this AUX button key event coz we met
the landscape flickering problem. When we are able to solve this problem, we
will put it back. Thanks for your opinion!

if you'd like to keep the original one, you may use this package.
neod - 0.1.0+svnr4040-r5 - Simple Neo1973 Daemon for Button Handling and Power
Management

comment:4 Changed 9 years ago by scaredycat@…

  • Status changed from closed to reopened
  • Resolution fixed deleted

The entire AUX menu has been removed, please can you put it back for gta01
owners and if needs be *just* remove the rotation option for gta02 users.

comment:5 Changed 9 years ago by danielmewes@…

This sounds quite weird to me. You could as well say "receiving delivery status
using openmoko-messages does not work, so lets remove openmoko-messages
completely until thats fixed".
Apart from landscape mode working actually very well on GTA01 (IMO at least), I
also think that the other options of the AUX menu (Screenshot and toggle
Fullscreen) are quite useful too.
So I would agree with Andy, that only the broken option should only be removed
for the hardware which it is broken on.

Perhaps there should be some "Rotating screen support" config flag to
disable/enable the appropriate option on different devices? This could also be
specified as a command line argument to neod, where the right flag could be
obtained by some switch structure in matchbox's session file, similar to the one
in /etc/default/gsmd, that specifies GSMD command line arguments depending on
the actual hardware OpenMoko? is runing on.

comment:6 Changed 9 years ago by erin_yueh@…

  • Status changed from reopened to assigned

yes, that is my fault, since i misunderstood what Will wants. We would like to
disable or remove SWAP orientation button from GTA02 devices on pressing AUX
key. I've already put the AUX key back today and will make a patch for GTA02
devices only. Thanks a lot for pointing out the problem!

Changed 9 years ago by erin_yueh@…

remove SWAP orientation button from option menu

Changed 9 years ago by erin_yueh@…

disable SWAP orientation button from option menu

comment:7 Changed 9 years ago by roh

  • Owner changed from erin_yueh@… to erin_yueh

comment:8 Changed 9 years ago by nomeata

  • Cc nomeata added

comment:9 Changed 9 years ago by john_lee

  • Status changed from assigned to closed
  • HasPatchForReview unset
  • Resolution set to community

Om2007.

Note: See TracTickets for help on using tickets.