Ticket #1284 (closed defect: community)

Opened 9 years ago

Last modified 8 years ago

Contacts are not sorted.

Reported by: scaredycat@… Owned by: openmoko-devel
Priority: high Milestone:
Component: openmoko-contacts Version: current svn head
Severity: normal Keywords:
Cc: buglog@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: no PatchReviewResult:
Reproducible:

Description

Contacts in the contacts application are not sorted alphabetically, which is the
norm for lists like this.

Change History

comment:1 Changed 9 years ago by kevin@…

I wonder if the wisdom of "do what's expected" works here. I've ALWAYS found
alpha sorting to be a pain - my wife lists me a "1kevin" to ensure that I'm at
the top of her list.

Would it not make more sense to have a "call count" that simply keeps a tally of
how often a contact calls or is called so that your most frequently used
contacts are always at the top?

comment:2 Changed 9 years ago by thomas@…

Actually, it is sorted alphabetically, but by the first letter, rather than by
surname.

comment:3 Changed 9 years ago by scaredycat@…

@Kevin

That might be ok if you only have a few contacts, but if you have a long list of
contacts how on earth are you going to find the one you want?

@Thomas

looks like an ASCII sort ie 'C' != 'c' which perhaps it should ie case
insensitive sort?

comment:4 Changed 9 years ago by roh

  • Owner changed from openmoko-devel@… to openmoko-devel

comment:5 Changed 8 years ago by john_lee

  • Status changed from new to closed
  • HasPatchForReview unset
  • Resolution set to community
Note: See TracTickets for help on using tickets.