Ticket #1285 (new defect)

Opened 6 years ago

Last modified 6 years ago

WLAN stability issue with WPA

Reported by: andy@… Owned by: openmoko-kernel
Priority: high Milestone:
Component: Wifi Version: unspecified
Severity: normal Keywords:
Cc: buglog@…, ace@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible:

Description

I have had a GTA02 up on WLAN (WPA, Belkin AP with default firmware) for
a couple of days now. I have some little experiences with it.

  • First it seemed there was something up with ARP for its IP. If I

pinged out from the GTA02 on WLAN, then my laptop can ping to the GTA02
WLAN IP. Before I pinged out from the GTA02, it seemed it did not get
an ARP query response and claimed there was no route despite everything
was set. It should have had an ARP request and response without that.

  • Next the connection did not stay nailed up for more than several

hours. When I examined the situation by connecting the debug board
console, and tried to ping again, I saw that wpa_supplicant reacted by
noting that association was lost, and reacquired it quickly. A
subsequent ping worked without doing anything else.

  • I reacted to this by doing

ping <router ip> &

on the GTA02 and it stayed up for a day or so. I noticed it was
unreachable again today.

  • When I examine again with the debug console, the ping is still

running but gives

recvfrom(netlink): No buffer space available

once a second. dmesg has this in it repeatedly

[241647.840000] AR6000 disconnected from 00:11:50:ad:ce:38
[241647.840000] Disconnect Reason is 4
[241647.845000] Protocol Reason/Status? Code is 4
[241647.845000] AssocResp? Frame = NULL
[241647.880000] AR6000 connected event on freq 2462 with bssid
00:11:50:ad:ce:38 listenInterval=100, beaconInterval = 100, beaconIeLen

26 assocReqLen=48 assocRespLen =22

[241647.885000] Network: Infrastructure
[241647.890000]
[241647.890000] BeaconIEs= 30 18 01 00 00 0f ac 02 02 00 00 0f ac 04 00
0f ac 02 01 00 00 0f ac 02 00 00
[241647.910000]
recvfrom(netlink): No buffer space available
[241647.910000] AssocRespIEs= 01 04 82 84 8b 96 32 08 8c 12 98 24 b0 48
60 6c
[241647.915000] AssocReqIEs= 00 04 66 72 6f 68 01 08 82 84 8b 0c 12 96
18 24 32 04 30 48 60 6c 30 14 01 00 00 0f ac 02 01 00 00 0f ac 04 01 00
00 0f ac 02 00 00
[241648.340000] WMI Control EP full, dropping packet : 0xC0AB76C0, len:2
[241648.355000] WMI Control EP full, dropping packet : 0xC0AB7780, len:47
[241648.400000] WMI Control EP full, dropping packet : 0xC565A900, len:2
[241648.410000] WMI Control EP full, dropping packet : 0xC565AF00, len:47

  • iwconfig does not list the logical WLAN network interface eth0 any more.

Unfortunately the crisis that left it in this state is flushed from the
dmesg buffer.

Change History

comment:1 Changed 6 years ago by roh

  • Owner changed from openmoko-kernel@… to openmoko-kernel

comment:2 Changed 6 years ago by gdevenyi

  • Cc ace@… added

comment:3 Changed 6 years ago by odlg

I have seen this as well with the original ASU 2008.8 kernel, except that iwconfig and ifconfig responds very slowly.

root@om-gta02:~# time iwconfig eth0
eth0      AR6000 802.11g  ESSID:""  
          Mode:Managed  Frequency:2.442 GHz  Access Point: 00:14:BF:E2:AD:49   
          Bit Rate=65.535 Mb/s   Tx-Power=0 dBm   Sensitivity=0/3  
          Retry:on   
          Encryption key:off
          Power Management:off
          Link Quality:186/94  Signal level:-165 dBm  Noise level:-96 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:20  Invalid misc:0   Missed beacon:16

real	0m 8.03s
user	0m 0.00s
sys	0m 0.02s

comment:4 Changed 6 years ago by emilis.info

cc: emilis.d@…

Note: See TracTickets for help on using tickets.