Ticket #1293 (closed defect: fixed)

Opened 10 years ago

Last modified 9 years ago

ScaredyCat's alternate theme

Reported by: scaredycat@… Owned by: openmoko-devel
Priority: high Milestone:
Component: Theming - Gtk+ Version: current svn head
Severity: normal Keywords:
Cc: buglog@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: no PatchReviewResult:
Reproducible:

Description

Alternative theme for openmoko

Attachments

replacement-openmoko-theme.tar.gz (169.1 KB) - added by scaredycat@… 10 years ago.
Alternative theme for openmoko
Screenshot-1.png (16.4 KB) - added by ebbe@… 9 years ago.
Very small buttons, no icons

Change History

Changed 10 years ago by scaredycat@…

Alternative theme for openmoko

comment:1 Changed 10 years ago by thomas@…

This theme is invalid unless Clearlooks is actually installed.

comment:2 Changed 10 years ago by scaredycat@…

Why? It doesn't use the Clearlooks.

comment:3 Changed 10 years ago by thomas@…

Using the theme:

(openmoko-calculator:1363): Gtk-WARNING : Unable to locate theme engine in
module_path: "clearlooks",
/home/root/.themes/openmoko-standard-2/gtk-2.0/openmoko-contacts:6: Unable to
locate image file in pixmap_path: "mokocontacts/add-detail-button.png"
/home/root/.themes/openmoko-standard-2/gtk-2.0/openmoko-contacts:9: Background
image options specified without filename
/home/root/.themes/openmoko-standard-2/gtk-2.0/openmoko-contacts:13: Unable to
locate image file in pixmap_path: "mokocontacts/add-detail-button.png"
/home/root/.themes/openmoko-standard-2/gtk-2.0/openmoko-contacts:16: Background
image options specified without filename
/home/root/.themes/openmoko-standard-2/gtk-2.0/openmoko-contacts:20: Unable to
locate image file in pixmap_path: "mokocontacts/add-detail-button.png"
/home/root/.themes/openmoko-standard-2/gtk-2.0/openmoko-contacts:23: Background
image options specified without filename
/home/root/.themes/openmoko-standard-2/gtk-2.0/openmoko-dates:6: Unable to
locate image file in pixmap_path: "mokodates/vborder-button.png"
/home/root/.themes/openmoko-standard-2/gtk-2.0/openmoko-dates:9: Background
image options specified without filename
/home/root/.themes/openmoko-standard-2/gtk-2.0/openmoko-dates:13: Unable to
locate image file in pixmap_path: "mokodates/vborder-button.png"
/home/root/.themes/openmoko-standard-2/gtk-2.0/openmoko-dates:16: Background
image options specified without filename
/home/root/.themes/openmoko-standard-2/gtk-2.0/openmoko-dates:20: Unable to
locate image file in pixmap_path: "mokodates/vborder-button.png"
/home/root/.themes/openmoko-standard-2/gtk-2.0/openmoko-dates:23: Background
image options specified without filename
/home/root/.themes/openmoko-standard-2/gtk-2.0/openmoko-dates:35: Unable to
locate image file in pixmap_path: "mokodates/hborder-button.png"
/home/root/.themes/openmoko-standard-2/gtk-2.0/openmoko-dates:38: Background
image options specified without filename
/home/root/.themes/openmoko-standard-2/gtk-2.0/openmoko-dates:42: Unable to
locate image file in pixmap_path: "mokodates/hborder-button.png"
/home/root/.themes/openmoko-standard-2/gtk-2.0/openmoko-dates:45: Background
image options specified without filename
/home/root/.themes/openmoko-standard-2/gtk-2.0/openmoko-dates:49: Unable to
locate image file in pixmap_path: "mokodates/hborder-button.png"
/home/root/.themes/openmoko-standard-2/gtk-2.0/openmoko-dates:52: Background
image options specified without filename
/home/root/.themes/openmoko-standard-2/gtk-2.0/gtkradiobutton:64: Unable to
locate image file in pixmap_path: "transparency100.png"
/home/root/.themes/openmoko-standard-2/gtk-2.0/gtkradiobutton:67: Background
image options specified without filename

comment:4 Changed 10 years ago by scaredycat@…

Right, but it doesn't actually use the clearlooks engine if it's not there.
removing the 'engine' section removes the error but doens't affect the appearance.

#engine "clearlooks"
# {
# sunkenmenubar = 1 # 0 = disable, 1 = enable
# menuitemstyle = 1 # 0 = flat, 1 = 3d-ish (button)
# listviewitemstyle = 1 # 0 = flat, 1 = 3d-ish (gradient)
# progressbarstyle = 0 # 0 = candy bar, 1 = flat
# }

So remove that and you wont get the engine error.

comment:5 Changed 9 years ago by ebbe@…

The theme almost makes the media player unusable.

comment:6 Changed 9 years ago by scaredycat@…

Please at leat give me a clue as to what your issues are Esben.

comment:7 Changed 9 years ago by ebbe@…

Oh, I thought is was obvious.
The Play, Forward etc are very small and without an icon.

Changed 9 years ago by ebbe@…

Very small buttons, no icons

comment:8 Changed 9 years ago by scaredycat@…

is this a direct downloaded version ( from my blog) or one on my images? The
picture seems to suggest the former, in which case I may have forgotten to
update that version. I have just uploaded the one that goes onto my images (same
url)

comment:9 Changed 9 years ago by scaredycat@…

Actually, this isn't my theme, this looks like Thomas Wood's reinterpretation of
my theme.

I knew I couldn't have released a buggy theme :P

comment:10 Changed 9 years ago by ebbe@…

Oh, maybe your right. It just came through 'opkg upgrade'. I don't know who made it.

comment:11 Changed 9 years ago by thomas@…

To be fair, this is an issue with openmoko-mediaplayer not distributing the
custom theme it uses. Instead it relies on the current theme to provide it's
custom appearance, which is only present in the old (openmoko-standard2) theme.

comment:12 Changed 9 years ago by cwixon@…

Yes, thos in #13 is right. Back when he first started working on the theme a
number of months ago, I fixed this problem with the media player by copying the
entire directory

/usr/share/themes/openmoko-standard-2/gtk-2.0/mokomediaplayer/

to

/usr/share/themes/Moko/gtk-2.0/

This is where all the media player icons live.

comment:13 Changed 9 years ago by roh

  • Owner changed from openmoko-devel@… to openmoko-devel

comment:14 Changed 9 years ago by john_lee

  • Status changed from new to closed
  • HasPatchForReview unset
  • Resolution set to fixed

with thomas' moko-gtk-theme in place I believe this is no longer valid.

Note: See TracTickets for help on using tickets.