Ticket #1301 (closed enhancement: community)

Opened 10 years ago

Last modified 5 months ago

Wrong keyboard displayed for phone number entry in Contacts

Reported by: andrew@… Owned by: openmoko-devel
Priority: high Milestone:
Component: openmoko-contacts Version: current svn head
Severity: minor Keywords:
Cc: buglog@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: no PatchReviewResult:
Reproducible:

Description

When I tap on "Add Phone Number" in Contacts, the on-screen keyboard that is
displayed comes up in alphanumeric mode rather than numeric mode. This means
each key has to be tapped multiple times in order to get the digit past the
three letters. This makes entering phone numbers very tiresome.

Change History

comment:1 Changed 10 years ago by andrew@…

  • Severity changed from normal to minor

Er, this is actually more minor than I thought -- it's just that the *default*
keyboard is in text mode. All one has to do is tap the "*" key to switch it to
numeric mode.

comment:2 Changed 10 years ago by erin_yueh@…

  • Status changed from new to closed
  • Resolution set to fixed

hi Andrew,
since you find out how to switch the input mode in the keyboard, i mark this bug
as fixed! Thanks!

comment:3 Changed 10 years ago by andrew@…

  • Status changed from closed to reopened
  • Resolution fixed deleted

Well, sure, but the point remains: it should come up by default in a mode
consistent with the type of entry field. If I'm expected to enter a phone
number, it should come up in dialpad mode. If it's a text field, it should come
up in alphanumeric mode.

comment:4 Changed 9 years ago by roh

  • Owner changed from openmoko-devel@… to openmoko-devel

comment:5 Changed 9 years ago by kenrestivo

  • Type changed from defect to enhancement

I suggest adding this as an enhancement. It bit me too, and it'll likely bite any new naive end-user who tries to use the phone.

comment:6 Changed 9 years ago by john_lee

  • Status changed from reopened to closed
  • HasPatchForReview unset
  • Resolution set to community

comment:7 Changed 5 months ago by Kennescoma

Buy Qsymia Without A Prescription <a href=http://viag1.xyz/how-much-is-viagra.php>How Much Is Viagra</a> Kamagra Billig Online Bestellen Kamagra Vs Silagra <a href=http://kama1.xyz/cheap-kamagra-tablets.php>Cheap Kamagra Tablets</a> Purchase Cialis From North America Online Renova No Prescription <a href=http://cial1.xyz/cialis-buy-online.php>Cialis Buy Online</a> Cialis 20mg No 12 Cialis 10 Doctissimo <a href=http://cial5mg.xyz/brand-cialis.php>Brand Cialis</a> Where To Buy Finasteride Propecia En Europa <a href=http://zol1.xyz/zoloft-online.php>Zoloft Online</a> Viagra Indian Pharmacy Buy Generic Prednisone Online <a href=http://viagra.ccrpdc.com/order-viagra-on-line.php>Order Viagra On Line</a> Como Conseguir Viagra Gratis Cialis Costo Svizzera <a href=http://cial5mg.xyz/need-to-order-cialis.php>Need To Order Cialis</a> Comprar Viagra Generica Foros Antibiotics Canada Over The Counter <a href=http://kama1.xyz/where-to-order-kamagra.php>Where To Order Kamagra</a> Acheter Du Cialis En Ligne Forum Viagra Online 25mg <a href=http://cial1.xyz/cialis-cost.php>Cialis Cost</a> Generic Paxil 40.Mg Effet Secondaire Cialis Generique <a href=http://viag1.xyz/low-price-viagra.php>Low Price Viagra</a> Achat Cialis Internet Avis Steady source of income. <a href=http://easymoneyfast-365.com>personal loan rates</a> How State Rate Limits Affect Payday Loan Prices.Itching Caused By Amoxicillin <a href=http://nolvadex.ccrpdc.com/buy-clomid-and-nolvadex-online.php>Buy Clomid And Nolvadex Online</a> Dutasteride Website No Physician Approval Le Cialis Naturel <a href=http://zol1.xyz/buy-sertraline-online.php>Buy Sertraline Online</a> Viagra E Metabolismo Cephalexin Dogs <a href=http://zithromax.ccrpdc.com/buy-cheap-zithromax.php>Buy Cheap Zithromax</a> Prix Du Cialis 5 Mg En Pharmacie Propecia Side Effects Recession <a href=http://cial5mg.xyz/low-price-cialis.php>Low Price Cialis</a> Cheap Kamagra Oral Jelly Online Buy Albuterol Inhaler Online Cheap <a href=http://zithromax.ccrpdc.com/azithromycin-500mg.php>Azithromycin 500mg</a> Viagra Indicaciones Cialis Original Livraison Rapide <a href=http://cial1.xyz/buy-cialis-online.php>Buy Cialis Online</a> Zithromax Good For Uti Viagra Vente Suisse <a href=http://cial5mg.xyz/cialis-buy.php>Cialis Buy</a> Vendita Viagra Slovenia Cialis Munchen <a href=http://cial1.xyz/cheap-cialis-tablets.php>Cheap Cialis Tablets</a> Comprar Cialis Diario

Note: See TracTickets for help on using tickets.