Ticket #1319 (closed defect: wontfix)

Opened 11 years ago

Last modified 2 years ago

sysfs RTC class device missing wakealarm capability

Reported by: mickey@… Owned by: openmoko-kernel
Priority: high Milestone:
Component: kernel Version: unspecified
Severity: normal Keywords:
Cc: buglog@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: no PatchReviewResult:
Reproducible:

Description

Our RTF can wake us up from suspend. Unfortunately, we don't enable this feature
in the RTC sys class interface hence the 'wakealarm' attribute is missing.

The corresponding code in RTC class is:

else if (rtc_does_wakealarm(class_dev)) {

/* not all RTCs support both alarms and wakeup */
err = class_device_create_file(class_dev,

Can we please add that?

Change History

comment:1 Changed 11 years ago by zecke@…

Sure.

comment:2 Changed 11 years ago by werner@…

BTW, I poked around a bit. The easiest approach is probably to copy the
hack from rtc-at91rm9200.c:at91_rtc_probe and call device_init_wakeup
directly.

There's also a call to it in i2c-core.c:i2c_new_device (triggered by
I2C_CLIENT_WAKE in struct i2c_board_info.flags), but that seems to be
intended for other purposes.

comment:3 Changed 11 years ago by zecke@…

I had a look as well and I think it is evil. In our case the RTC device is our
PMU which has a lot of wakeup sources (usb insert, remove, battery, power
button). You do not want to disable wakeup for the power button from userspace.

To make this somewhat sane (e.g. to only apply to the alarm), we will need to
add another (platform_)device for the rtc and make sure masking the alarm
interrupt is not undone by the suspend code of the pcf routine... or do other
evil things...

comment:4 Changed 11 years ago by roh

  • Owner changed from openmoko-kernel@… to openmoko-kernel

comment:5 Changed 10 years ago by john_lee

  • HasPatchForReview unset

wow 7 months old. any update?

comment:6 Changed 10 years ago by mickey

  • Status changed from new to closed
  • Resolution set to wontfix

Since the ioctl interface works, I no longer care whether we have the sysfs wakealarm interface available or not. Closing as WONTFIX.

comment:7 Changed 2 years ago by Chassmetly

Sildenafil 10 Mg <a href=http://cial5mg.xyz/cialis-online-buy.php>Cialis Online Buy</a> isotretinoin 20mg Purchase Propecia <a href=http://cial1.xyz/map.php>Buying Cialis Online</a> Buy Delgra 200 Mg Buy Albuterol Inhaler Online Cheap <a href=http://cial1.xyz/cialis-price.php>Cialis Price</a> Achat De Viagra Au Canada Buy Clomiphene Citrate Canada <a href=http://viag1.xyz/viagra-discount-sales.php>Viagra Discount Sales</a> Levitra Vardenafil 20mg Pfizer Vgr 100 <a href=http://cial5mg.xyz/cheapest-cialis-online.php>Cheapest Cialis Online</a> Generic Celebrex India Food Interactions With Amoxicillin <a href=http://zol1.xyz/generic-zoloft-online.php>Generic Zoloft Online</a> Clomid Next Day Delivery Propecia Zorgverzekering <a href=http://priligy.ccrpdc.com/buy-dapoxetine-priligy-online.php>Buy Dapoxetine Priligy Online</a> Propecia Epididimitis 100mg Viagra For Sale <a href=http://kamagra.ccrpdc.com/buy-cheap-kamagra.php>Buy Cheap Kamagra</a> Orislat Buy Online Canadian Ems Kamagra Oral Disfuncion Erectil <a href=http://viag1.xyz/generic-sildenafil.php>Generic Sildenafil</a> Bien Hora Para Tomar Propecia Cialis Samples Free <a href=http://zol1.xyz/zoloft-buy-online.php>Zoloft Buy Online</a> overnight Pharm Brand Cialis Viagra Libyen <a href=http://cial1.xyz/cialis-generic.php>Cialis Generic</a> Buy Zoloft Sans Ordonnance Amoxicillin Pharmacie En Ligne Ordonnance <a href=http://levitra.ccrpdc.com/levitra-buy-us.php>Levitra Buy Us</a> Bupropion Generique Cialis Forum <a href=http://viag1.xyz/order-viagra.php>Order Viagra</a> Generic Levitra Does It Work Orlistat Indications <a href=http://zol1.xyz/cheap-zoloft-online.php>Cheap Zoloft Online</a> Where Can I Buy Cialis On Line Levitra Dopo Mangiato <a href=http://zol1.xyz/cheap-zoloft-without-prescription.php>Cheap Zoloft Without Prescription</a> Kamagra 100 Mgs Buy Low Cost Dapoxetine Pills <a href=http://cial5mg.xyz/cialis-on-line.php>Cialis On Line</a> Metformin Without A Prescription Discount Fedex Stendra Overseas <a href=http://kama1.xyz/order-kamagra-tablets.php>Order Kamagra Tablets</a> Lasix Pills Online Viagra Et Effets Indesirables <a href=http://cial5mg.xyz/cheap-cialis-generic.php>Cheap Cialis Generic</a> Viagra E Dieta Cialis Lilly Icos <a href=http://cial5mg.xyz/tadalafil-online.php>Tadalafil Online</a> Bentyl 20mg Diciclomina Viagra Pillen Kaufen <a href=http://zol1.xyz/buy-zoloft-online-cheap.php>Buy Zoloft Online Cheap</a> What Is Amoxil Used For Cytotec Comprar <a href=http://cial1.xyz/cialis-viagra.php>Cialis Viagra</a> Levitra Generico Gratis

Note: See TracTickets for help on using tickets.