Ticket #1322 (closed defect: wontfix)

Opened 9 years ago

Last modified 9 years ago

Background noise during conversation

Reported by: allen_lin@… Owned by: erin_yueh
Priority: highest Milestone:
Component: hardware Version: current svn head
Severity: major Keywords:
Cc: buglog@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: no PatchReviewResult:
Reproducible:

Description

When talking through Neo FreeRunner?, there is no background noise at Neo
FreeRunner? side, but some noise at another phone side.

uImage-2.6.24+svnr4301-r4251-r5-om-gta02.bin
Openmoko-openmoko-freerunner-image-glibc-ipk-P1-Snapshot-20080403-om-gta02.rootfs.jffs2

Change History

comment:1 Changed 9 years ago by werner@…

Following up on the GTA02 phone conference:
The ALSA-related item is "Amp Stat". Muting it kills the GSM download
noise, but the mechanism if independent from
/sys/devices/platform/neo1973-pm-gsm.0/download

Thus, the "time bomb" only ticks if
Amp_Stat != Muted && download == enabled

where the value of "enabled" is 1 without Holger's patch, and 0 without it.

Since u-boot already sets this GPIO to the correct value, the easiest
solution is if Linux does not change it. In my somewhat dated rootfs, I
found the following places where it does change it:

/etc/init.d/gsmd:

[ -n "$GSM_DL" ] && ( echo "1" >$GSM_DL; sleep 1 )

So just removing this line should solve the problem. It may also be worth
checking if gsmd or any wrapper or such tries to change "GSM_DL" as well.

Oh, and svn.internal.openmoko.org/trunk/production_testing/gta02-dm2/src/dm2.c
has a few writes to /sys/bus/platform/devices/neo1973-pm-gsm.0/download,
so this probably needs some updating as well.

comment:2 Changed 9 years ago by erin_yueh@…

  • Status changed from new to assigned

John updated this gsmd script and uploaded it to OE. Thanks! Werner! :)

comment:3 Changed 9 years ago by roh

  • Owner changed from erin_yueh@… to erin_yueh

comment:5 Changed 9 years ago by john_lee

  • Status changed from assigned to closed
  • Resolution set to wontfix
  • HasPatchForReview unset
  • Component changed from openmoko-dialer to hardware
Note: See TracTickets for help on using tickets.