Ticket #1326 (closed defect: fixed)

Opened 11 years ago

Last modified 11 years ago

Missed call icon in home screen is incorrect

Reported by: erin_yueh@… Owned by: erin_yueh@…
Priority: high Milestone:
Component: openmoko-today Version: 2007.2
Severity: normal Keywords:
Cc: buglog@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible:

Description

as title

Attachments

Screenshot-1.png (243.3 KB) - added by erin_yueh@… 11 years ago.
screenshot
Screensh2ot-2.png (16.9 KB) - added by erin_yueh@… 11 years ago.
broken image

Change History

comment:1 Changed 11 years ago by thomas@…

  • Summary changed from cannot display missed call icon in home screen to Missed call icon in home screen is incorrect

comment:2 Changed 11 years ago by thomas@…

Restarting openmoko-today makes the icon appear, so I imagine the icons are
being loaded before the current icon theme is set.

Changed 11 years ago by erin_yueh@…

screenshot

Changed 11 years ago by erin_yueh@…

broken image

comment:3 Changed 11 years ago by thomas@…

I experimented by adding "sleep 2" after settings-daemon is loaded and this
appeared to fix the problem.

I also noticed this issue only occurs after rebooting and does not occur when
simply restarting X.

The reason the icons may not be loaded, is because they are only present in
openmoko-standard icon theme. This theme is not set if settings-daemon has not
finished loading by the time openmoko-today starts, which means the icons load
as "missing".

It seems the proper way to fix this would be to load the icons as built in to
the libmokoui library. We can also fix this issue by prevent settings-daemon
from forking before it has finished loading.

comment:4 Changed 11 years ago by thomas@…

I have made the change to settings-daemon in r2006. Please check with this
version to see if you can still reproduce this bug.

comment:5 Changed 11 years ago by thomas@…

Please note, the '&' needs to be removed from
/etc/X11/Xsession.d/70settings-daemon before this fix will work

comment:6 Changed 11 years ago by thomas@…

  • Owner changed from thomas@… to erin_yueh@…

I think this is fixed now. Could someone please verify?

comment:7 Changed 11 years ago by erin_yueh@…

  • Status changed from new to closed
  • Resolution set to fixed

It's fixed. Verified it by
Openmoko-openmoko-freerunner-image-glibc-ipk-P1-Snapshot-20080417-om-gta02.rootfs.jffs2

comment:8 Changed 11 years ago by erin_yueh@…

verified it and it's OK now. then close it.

Note: See TracTickets for help on using tickets.