Ticket #1339 (closed defect: duplicate)

Opened 11 years ago

Last modified 11 years ago

matchbox-keyboard sometimes has a locked enter key

Reported by: reddog@… Owned by: mickey@…
Priority: high Milestone:
Component: openmoko-keyboard Version: 2007.2
Severity: normal Keywords:
Cc: buglog@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible:

Description

I have replaced the multitap-thing with the matchbox-keyboard!
If i

  1. start openmoko-contacts
  2. press the ADD button
  3. enter a name and a number
  4. press the enter key of the keyboard, right after i entered the number

the application switches between keyboard and no-keyboard very fast, it can't
decide what it wants.
If i switch to another application, i can see that the enter-key is still
pressed. If if press it again, blinking stops...

I noticed this, because openmoko-contacts just dials the last selected number if
i get back to the main list, with this locked enter key.

Change History

comment:1 Changed 11 years ago by pwolszczak@…

The same with hald-addon-keyboard.
Sometimes [Ret] key leaves switch on like [Caps Lock].
When Neo try to open in Home: Dialer, Lupe, Trash or other, for example new
terminal in loop, You have to show keyboard and switch off (shaded) [Ret] key.

comment:2 Changed 11 years ago by ebbe@…

  • Status changed from new to closed
  • Resolution set to duplicate

* This bug has been marked as a duplicate of 970 *

Note: See TracTickets for help on using tickets.