Ticket #1352 (closed defect: wontfix)

Opened 6 years ago

Last modified 5 years ago

Some noise via headset

Reported by: allen_lin@… Owned by: hardware
Priority: high Milestone:
Component: hardware Version: current svn head
Severity: normal Keywords:
Cc: buglog@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: no PatchReviewResult:
Reproducible:

Change History

comment:1 Changed 6 years ago by erin_yueh@…

  • Owner changed from erin_yueh@… to sean_chiang@…

Sean, could you please check this issue? thanks!

comment:2 Changed 6 years ago by sean_chiang@…

  • Status changed from new to assigned

The noise is coming from RF interference.

comment:3 Changed 6 years ago by sean_chiang@…

  • Status changed from assigned to new
  • Owner changed from sean_chiang@… to openmoko-kernel@…

comment:4 Changed 6 years ago by andy@…

Well, there are only two likely possibilities.

RF interference is picked up by some aux MIC channel on the codec that is high
impedence and couples to it. Then we can solve this by turning off mixing
this signal into what is captured (test using Alsamixer).

RF interference couples to our ACTUAL mic signal. I don't know what we can do
about that in kernel :-)

comment:5 Changed 6 years ago by roh

  • Owner changed from openmoko-kernel@… to openmoko-kernel

comment:6 Changed 6 years ago by john_lee

  • Status changed from new to assigned
  • Owner changed from openmoko-kernel to hardware
  • HasPatchForReview unset
  • Component changed from openmoko-dialer to hardware

comment:7 Changed 6 years ago by john_lee

  • Blocking 1640 added

comment:8 Changed 5 years ago by wendy_hung

  • Blocking 1640 removed

comment:9 Changed 5 years ago by andy

  • Status changed from assigned to closed
  • Resolution set to wontfix

This isn't going to get fixed, no point tracking it.

Note: See TracTickets for help on using tickets.