Ticket #1354 (closed defect: worksforme)

Opened 9 years ago

Last modified 2 months ago

Cannot resume from suspend if suspend more than 30 minutes

Reported by: allen_lin@… Owned by: openmoko-kernel
Priority: highest Milestone:
Component: kernel Version: current svn head
Severity: critical Keywords:
Cc: buglog@…, nomeata Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: no PatchReviewResult:
Reproducible:

Change History

comment:1 Changed 9 years ago by andy@…

Hey this is a good test. We didn't expect suspend duration-based issues.

Can you explain about the "crash", maybe find some log evidence in dmesg or X
log if it is that.

comment:2 Changed 9 years ago by andy

We are studying this on kernel list the last days with Sean McNeil?, I did not manage to reproduce yet but he can get this error frequently.

comment:3 Changed 9 years ago by calestyo

I suffer from the same problem.
If my system was for some time in standby, I cannot resume it,... the only thing that helps is removing the battery.

Has there been any progress in this issue?

comment:4 Changed 9 years ago by relei

Hallo,

I have the same problem and only removing the battery helps.

MY phone data:

S/N: 8A8603440
Date Code: 20080617
P/N: 56-21147-00

If you need more information I try to give you.

comment:5 Changed 9 years ago by roh

  • Owner changed from openmoko-kernel@… to openmoko-kernel

comment:6 Changed 9 years ago by emilis.info

I was trying hard to reproduce this bug today, but nothing seems to work.

I have a FreeRunner? with latest updates (opkg update & upgrade).

I started investigating the bug, when I left my FreeRunner? connected to my laptop and on returning noticed the unresponsive phone, but usb0 ssh connection still open. Didn't know how to get all logs at the time, so I only have ps aux diff before and after starting X server:

emilis@emilis-laptop:~/work/neo$ diff ps1.txt ps2.txt 
27c27
< root      1071  0.0  0.0      0     0 ?        S<   12:26   0:00 [krfcommd]
---
> root      1071  0.0  0.0      0     0 ?        S<   12:25   0:00 [krfcommd]
30c30
< root      1403  6.6  4.0  18712  5172 ?        S<Lsl 12:27   6:44 /usr/bin/pulseaudio --no-cpu-limit --resample-method=trivial -D -nF /etc/pulse/session
---
> root      1403  6.6  4.0  18712  5176 ?        S<Lsl 12:27   6:48 /usr/bin/pulseaudio --no-cpu-limit --resample-method=trivial -D -nF /etc/pulse/session
47,48c47,48
< root      6911  0.0  0.4   1684   524 ?        Ss   13:28   0:00 /usr/sbin/gsmd gsmd -p /dev/ttySAC0 -s 115200 -F -d -l syslog
< root      7682  0.3  0.6   2264   872 ?        Ss   14:05   0:00 /usr/sbin/dropbear -r /etc/dropbear/dropbear_rsa_host_key -p 22
---
> root      6911  0.0  0.4   1684   596 ?        Ss   13:28   0:00 /usr/sbin/gsmd gsmd -p /dev/ttySAC0 -s 115200 -F -d -l syslog
> root      7682  0.2  0.6   2264   872 ?        Ss   14:05   0:00 /usr/sbin/dropbear -r /etc/dropbear/dropbear_rsa_host_key -p 22
50c50,67
< root      7688  0.0  0.7   2248   884 pts/0    R+   14:09   0:00 ps aux
---
> root      7695  0.1  0.5   2572   700 pts/0    S    14:09   0:00 xinit /etc/X11/Xsession -- /usr/bin/Xglamo :0 -pn -dpi 285 -screen 480x640 -hide-cursor -root-ppm /usr/share/pixmaps/xsplash-vga.ppm
> root      7699  5.8  3.8   8276  4872 pts/0    S<   14:09   0:02 /usr/bin/Xglamo :0 -pn -dpi 285 -screen 480x640 -hide-cursor -root-ppm /usr/share/pixmaps/xsplash-vga.ppm
> root      7704  0.0  0.5   2676   648 pts/0    S    14:09   0:00 /bin/sh /etc/X11/Xsession
> root      7709  1.9  0.6   2244   828 ?        Ss   14:09   0:00 /usr/bin/dbus-daemon --fork --print-pid 4 --print-address 6 --session
> root      7712  0.0  0.4   2680   536 pts/0    S    14:09   0:00 run-parts /etc/X11/Xsession.d
> root      7716  0.9  1.2   3444  1544 pts/0    S    14:09   0:00 /usr/libexec/gconfd-2
> root      7720  0.0  1.1   8156  1480 pts/0    S    14:09   0:00 /usr/bin/settings-daemon
> root      7722  0.7  1.5   5436  1972 pts/0    S    14:09   0:00 matchbox-keyboard -d
> root      7725  1.5  2.8  11332  3624 pts/0    S    14:09   0:00 multitap-pad -d
> root      7727 11.3  2.8  22512  3548 pts/0    Sl   14:09   0:04 neod
> root      7728 14.0 11.1  34096 14132 pts/0    S    14:09   0:05 openmoko-today
> root      7729 10.1  8.4  30208 10636 pts/0    Sl   14:09   0:03 phone-kit
> root      7730  1.7  2.5   7768  3192 pts/0    S    14:09   0:00 matchbox-window-manager -use_titlebar yes -use_desktop_mode decorated -theme Moko -use_cursor no
> root      7731  4.1  4.0  13452  5152 pts/0    S    14:09   0:01 matchbox-panel-2 --start-applets systray,startup --end-applets openmoko-panel-battery,openmoko-panel-gsm,openmoko-panel-gps,openmoko-panel-usb,openmoko-panel-bt,openmoko-panel-memory,openmoko-panel-wifi --titlebar
> root      7734  2.4  2.7   8080  3432 ?        S    14:09   0:00 /usr/libexec/e-calendar-factory
> root      7736  1.5  2.0  31356  2628 ?        S    14:09   0:00 /usr/libexec/e-addressbook-factory
> root      7747 69.5  7.7  22260  9840 ?        R    14:10   0:01 /usr/libexec/notification-daemon
> root      7748 17.0  0.7   2248   884 pts/0    R+   14:10   0:00 ps aux

What I tried today:

  • powersave: dim + phone locked manually (I don't like having to wake up the phone with power button)
  • wifi (as much as I remember): always turned off after starting
  • no applications running / dialer running / dialer + messages running / dialer + messages running, terminal launched and exited

I think when I restarted X server it asked me to supply my PIN number. The fact that X crashes for no apparent reason and inability to reproduce the bug leads me to guess it might be due to something from gsmd -- maybe some GSM event causes X to crash. I turn off Wifi, BT and GPS, so I see no other input sources for the device.

comment:7 Changed 9 years ago by relei

The GSM must turn on and you must selected „Dim first, then lock“. Only in this combination you can reproduce the error.

comment:8 Changed 9 years ago by nomeata

  • Cc nomeata added

comment:9 follow-up: ↓ 10 Changed 9 years ago by tfm

Problem appears with Qtopia too. Is there any progress on the issue?
I don't know how to get any log files. When the phone is not responding after a long suspend, ssh is not working either.
Are dmesg saved to any file that could be inspected after reboot?
I can run tests if you tell me how.

comment:10 in reply to: ↑ 9 Changed 9 years ago by tfm

Replying to tfm:
Issue has changed for me. Don't know if it is related to a new kernel. With qtopia and newest kernel through opkg update I have the following:
when resuming after long suspend the FR resumes correctly. Just the first 20 sec the screen is all white. But the device is working already, e.g. it's ringing.

comment:11 Changed 9 years ago by john_lee

  • Status changed from new to closed
  • HasPatchForReview unset
  • Resolution set to worksforme

Don't happen to me with the latest stable kernel.

comment:12 Changed 2 months ago by JustDox

Propecia Cheapest Secure <a href=http://xenical.ccrpdc.com/buy-online-xenical.php>Buy Online Xenical</a> Sinusitis Treatment Amoxicillin Sale Bentyl Dibent With Free Shipping <a href=http://cial5mg.xyz/where-to-order-cialis.php>Where To Order Cialis</a> Where Can You Buy Pct Pills? Vt Logistics Singapore Viagra <a href=http://zol1.xyz/zoloft-prices.php>Zoloft Prices</a> Zithromax Safe During First Trimester Kamagra Oral Jelly Ajanta <a href=http://kama1.xyz>Buy Kamagra</a> Effetti Cialis Vista Cialis Bugiardino <a href=http://nolvadex.ccrpdc.com/generic-nolvadex.php>Generic Nolvadex</a> Ou Acheter Cialis En Ligne Forum Generic Viagra Generic Meltabs Viagra <a href=http://cial1.xyz/buy-online-cialis.php>Buy Online Cialis</a> Risultati Finasteride Propecia Thyroxine Medication Online <a href=http://zol1.xyz/buy-cheap-zoloft-on-line.php>Buy Cheap Zoloft On Line</a> Propecia Veneno Andorra Does Cephalexin Kill Coccidia <a href=http://viagra.ccrpdc.com/purchase-viagra-usa.php>Purchase Viagra Usa</a> Cheap Viagra Super Active Plus Cat Amoxicillin Dosage <a href=http://cial5mg.xyz/tadalafil.php>?Tadalafil</a> Online Pharmacy Without Prescription

Note: See TracTickets for help on using tickets.