Ticket #1372 (closed defect: invalid)

Opened 11 years ago

Last modified 11 years ago

complete freeze of freerunner prottype #47

Reported by: mdt@… Owned by: sean_chiang@…
Priority: high Milestone:
Component: Core System Version: GTA02v4
Severity: normal Keywords:
Cc: buglog@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible:

Description

since 2 weeks or so i have complete freezes with my freerunner (prototype #47).
sometimes the device works for 2 days, sometime the crash comes minutes after
reboot. because i am activly developing my softwarestack the circumstances are
changing all the time. i use nearly the whole hardware in the neo:

  • gsm with the muxer
  • 2 channel for the gsmd
  • 1 channel for steady on gprs
  • gps
  • udp over usb to the host for syslog
  • grafic with evas with animation initiated by incomming messages
  • sd card access for the underlaying database

i tried to not use one or more components to determine which component was the
cause of the failure but because i have to develop my software it is difficult
to say something deterministic about it.

  • when the muxer is running in verbose mode, it logs more to syslog and the

freeze happened more often

  • often the freeze happened when messages arrived which triggered animation and

stored on sd

  • while my gpsd makes comparable high load, it seemed not to be involved

because in the office i don't use it and see freezes

i am completly lost and would be happy about any help on this issue. i am not an
hw guy and am helpless when using the debugboard (my first impressions see under
#1371 ).

Change History

comment:1 Changed 11 years ago by mdt@…

  • Status changed from new to closed
  • Resolution set to invalid

after a complete reflashing an nand erase the bug did not occure anymore. sry
for this report.

Note: See TracTickets for help on using tickets.