Ticket #1380 (closed defect: wontfix)

Opened 11 years ago

Last modified 2 years ago

GSM modem sleeps on virtual channels in MUX

Reported by: mickey@… Owned by: sean_chiang@…
Priority: high Milestone:
Component: GSM Modem Version: GTA02v5
Severity: normal Keywords:
Cc: buglog@…, tuju@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: no PatchReviewResult:
Reproducible:

Description

Tests with the gsm0710muxd show that the TI Calypso falls into deep sleep per
_virtual channel_, which is completely bogus, because the MUX mode has its own
power saving commands (PSC). Can we fix that in the firmware?

Change History

comment:1 Changed 11 years ago by mdt@…

while \r\n is the wakeup sequence in standard mode there is a wakeup-sequence in
muxer mode for the calypso (see #1289) also. i don't know why a per channel
sleep should make sence (wakeup in one channel does not wake up all other).

even more strange is that this does not happen if gprs is on. there is no wakeup
needed in any channel if gprs/ppp is used on one channel.

comment:2 Changed 11 years ago by tuju@…

  • Cc tuju@… added

comment:3 Changed 11 years ago by sean_chiang@…

  • Status changed from new to assigned

comment:4 Changed 11 years ago by mickey@…

I'm going to do much more tests for this bug. I do not yet fully trust our test
cases where this behaviour has ben seen. I will update you on the status.

comment:5 Changed 11 years ago by mdt@…

after heavy testing i have another behavior:

after around 6 days with gsm on (most of the time even using gprs also) the
modem stopped responding to commands on all channels. \r\n didn't wake it up.
stopping the pygsmd and using the first channel did not help. still no responses
at all.

after restarting the muxer (which issues the echo 0 > /sys...) the behavior was
different: most of the commands (but not all, pure device commands like requests
vor vendor, product, version and serial succeeded) gave the good old error "+CME
ERROR: failed to abort" (or similar, not shure, the log is lost). after a
restart of the pygsmd the error did not occure again.

i'm not shure if this observation is related to pm/psc.

comment:6 Changed 11 years ago by mickey@…

Multiple automated tests now confirm that the enter the sleep individually per
virtual channel, however once the first channel has been woken up
(either by receiving an unsolicited response or a command that is terminated
with \r\n [which will receive no response]), all virtual channels wake up.

Until we have a proper fix, I will work around this by using a dedicated
KeepAlive? channel that keeps the modem alive (sic!) :(

I would consider one of the following solutions as a proper fix from the side of
the modem, with c) being the most wanted solution, a) or b) being acceptable and
d) being the very last resort.

a) stop sleeping on virtual channels and receive act on PSC wakeup, or
b) stop sleeping on virtual channels and send PSC sleep command, or
c) a) + b)
d) continue sleeping on virtual channels, but accept a special AT wakeup command
that does not send 'OK' if the modem is already woken up.

comment:7 Changed 11 years ago by mickey@…

  • Status changed from assigned to closed
  • Resolution set to wontfix
  • Severity changed from critical to normal

For the records, EOF (\x1a) seems to also wakeup the modem and in contrast to
\r\n, it does not emit an 'OK' if the modem is already woken up.

With that and a global modem communication timestamp, I think we can settle this
issue. Since I'm pretty sure that no one inside Openmoko nor TI will attempt to
fix this properly (see #1289), I will now close this as WONTFIX and limit the
severity since we have a workaround.

comment:8 Changed 10 years ago by mickey

  • HasPatchForReview unset

And even more for the records, although probably no one is reading this anymore... my analysis was wrong, it doesn't sleep on the virtual channels, it sleeps in multiplexing mode and needs to be sent a full frame (not just flag characters) to be woken up correctly. With regards to the original problem, it's no longer a problem at all, since you can even wake it up properly on mux layer (which is what fso-abyss does) and no longer have to care on the AT layer.

Case closed :)

comment:9 Changed 2 years ago by Chassmetly

Cialis Kaufen In Berlin <a href=http://cial5mg.xyz/cialis-free-trial.php>Cialis Free Trial</a> No Pain Tooth Infection And Amoxicillin Viagra Vente Qubec <a href=http://viag1.xyz/china-viagra-online.php>China Viagra Online</a> Cialis Precio 5 Mg 25 Mg Cialis <a href=http://cial5mg.xyz/get-cheap-cialis-online.php>Get Cheap Cialis Online</a> Fluoxetine Panic Attacks Viagra Uso En Jovenes <a href=http://kama1.xyz/order-kamagra-onlines.php>Order Kamagra Onlines</a> Cialis Italiano Online Rx <a href=http://cial5mg.xyz/cialis-prices.php>Cialis Prices</a> where can i buy accutane yahoo Eastern Canada Pharmacy For Levitra <a href=http://cial1.xyz/cheap-cialis-tablets.php>Cheap Cialis Tablets</a> Online Pharmacy India Tamoxifen 20 Mg Maxifort <a href=http://zol1.xyz/getting-zoloft-overseas.php>Getting Zoloft Overseas</a> Augmentin Vs Amoxicillin Buy Thyroxine Online India <a href=http://cial1.xyz/shop-cialis-online.php>Shop Cialis Online</a> How To Take Priligy Where To Purchase Chat Lagyl <a href=http://cial5mg.xyz/order-cialis-in-usa.php>Order Cialis In Usa</a> Viagra Free Belgium Acheter Viagra Pfizer 100mg <a href=http://kama1.xyz/purchase-generic-kamagra.php>Purchase Generic Kamagra</a> How To Identify Amoxicillin From Mexico Viagra Avis <a href=http://zol1.xyz/buy-cheap-zoloft.php>Buy Cheap Zoloft</a> Cialis From Usa Pharmacy Quiero Comprar Cialis Espana <a href=http://levitra.ccrpdc.com/buy-levitra-vardenafil.php>Buy Levitra Vardenafil</a> Keflex Dosage Canine Generic Online Macrobid 100mg Internet Canada Overseas Without Rx Oregon <a href=http://prozac.ccrpdc.com/fluoxetine-20mg.php>Fluoxetine 20mg</a> Silibinin Viagra Online Overnight Delivery <a href=http://cial1.xyz/buy-cialis-online-usa.php>Buy Cialis Online Usa</a> Efectos De Cialis Foros Viagra Fur Manner Kaufen <a href=http://zol1.xyz/generic-zoloft.php>Generic Zoloft</a> Buy Atenolol With Online Dr. Prescribe Cephalexin Shortage <a href=http://kama1.xyz/cheap-kamagra-uk.php>Cheap Kamagra Uk</a> How Can I Save Money On Viagra Cialis Caducado <a href=http://kama1.xyz/cost-of-kamagra.php>Cost Of Kamagra</a> Inhouse Pharmacy Amoxicillin Mer <a href=http://cial1.xyz/buy-cialis.php>Buy Cialis</a> Pediatric Dosage Of Amoxicillin Kamagra Safety <a href=http://cial1.xyz/buy-online-cialis.php>Buy Online Cialis</a> Cialis En Farmacias De Andorra Ou Curetage Pris Du Cytotec <a href=http://zol1.xyz/zoloft-online-prices.php>Zoloft Online Prices</a> Cialis Italia Online Erection Pills With No Perscription <a href=http://zol1.xyz/zoloft-online.php>Zoloft Online</a> Kamagra 100 Mg Saint Cialas In Canada <a href=http://cialis.ccrpdc.com/cialis-online-cs.php>Cialis Online Cs</a> Amoxicillin Allergic Pyridium 200mg For Sale Aberdeen <a href=http://zithromax.ccrpdc.com/azithromycin-250mg.php>Azithromycin 250mg</a> Mixing Amoxicillin With Penicillin Dapoxetina Ebay <a href=http://zol1.xyz/zoloft.php>Zoloft</a> Buy Clomid Pills Online In The Uk Effetto Kamagra <a href=http://zol1.xyz/zoloft-implicane.php>Zoloft Implicane</a> Avana (Stendra) 50mg Priligy Johnson Et Johnson <a href=http://kama1.xyz/cheap-kamagra-uk.php>Cheap Kamagra Uk</a> Propecia Parafarmacia

Note: See TracTickets for help on using tickets.