Ticket #1382 (closed defect: fixed)

Opened 11 years ago

Last modified 10 years ago

verbose mmc-related kernel messages slow down boot process (GTA01)

Reported by: thebohemian@… Owned by: openmoko-kernel@…
Priority: high Milestone:
Component: kernel Version: unspecified
Severity: normal Keywords:
Cc: buglog@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible:

Description

The current kernel prints a lot of messages when accessing the MMC/SD-card (e.g.
when booting from it) which slows down the boot process considerably. The kernel
messages look like this one:

mmc0: req done (CMD18): 0: 00000900 d35983c7 befb4fff 92404021
mmc0: 1024 bytes transferred: 0
mmc0: (CMD12): 0: 00000b00 7f5983c7 befb4fff 92404021

It would be nice if their urgency level could be lowered so that they only show
up when needed.

Change History

comment:1 Changed 11 years ago by andy@…

  • Status changed from new to assigned

This is MMC DEBUG traffic that has been enabled by accident in GTA01 config for
a while until last week. If you're still seeing it even on most recent kernels
then there is some issue about which config the OE build is using, because it is
fixed in stable git tree.

comment:2 Changed 10 years ago by andy

  • Status changed from assigned to closed
  • Resolution set to fixed

Closing as fixed.

Note: See TracTickets for help on using tickets.