Ticket #1415 (closed defect: community)

Opened 9 years ago

Last modified 8 years ago

Cannot power on GSM Antenna

Reported by: lackita@… Owned by: openmoko-kernel
Priority: high Milestone:
Component: kernel Version: GTA02v6
Severity: critical Keywords:
Cc: buglog@…, jeffrey.ratcliffe+omdocs@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: no PatchReviewResult:
Reproducible:

Description

Whenever I try to power on my antenna, I get the error "Modem power-up failed:
10". Also, if I try to manually register with the network, I get an error after
'AT+CPIN="...."'. I'd include additional log files, but I'm not sure what files
would be useful.

Change History

comment:1 Changed 9 years ago by JJR

  • Version GTA01Bv4 deleted
  • Severity changed from normal to critical

I am also seeing this on my GTA02

comment:2 Changed 9 years ago by JJR

  • Version set to GTA02v6

comment:3 Changed 9 years ago by JJR

  • Cc jeffrey.ratcliffe+omdocs@… added

comment:4 Changed 9 years ago by roh

  • Owner changed from sean_chiang@… to sean_chiang

comment:5 Changed 9 years ago by robolange

Any update on this annoying bug? Any intuition why it is failing?

In my experience, I use libgsmd-tool -m shell and use the O command to power up the antenna. Nondeterministically with probability about 0.9 (guess), it will fail and produce the error noted. With probability about 0.1, it will succeed. I just keep issuing the O command until it succeeds, which is usually after around 10 or so tries. After that, registration typically proceeds correctly.

I have device GTA02Bv5, firmware Moko8. I use OM2007.2 with the latest updates from opkg.

comment:6 Changed 8 years ago by john_lee

  • Status changed from new to assigned
  • Owner changed from sean_chiang to openmoko-kernel
  • HasPatchForReview unset
  • Component changed from GSM Modem to System Software

comment:7 Changed 8 years ago by john_lee

not sure if this is related to libgsmd or a general issue. if it's libgsmd specified then we should resolved as community.

comment:8 Changed 8 years ago by robolange

I have since upgraded to OM2008.9 and this bug does not appear to be present in that distribution. Because OM2007.2 seems to be a buggy and dead distribution (although, one that for reasons unknown is still shipped with the phones), we might just want to recommend an upgrade to those affected, and close this bug.

comment:9 Changed 8 years ago by john_lee

  • Status changed from assigned to closed
  • Resolution set to community
Note: See TracTickets for help on using tickets.