Ticket #1420 (closed defect: fixed)

Opened 11 years ago

Last modified 11 years ago

Battery icon does not change immediately when plug USB or Charger.

Reported by: regina_kim@… Owned by: zecke
Priority: normal Milestone: Om2008.8
Component: kernel Version: GTA02v5
Severity: normal Keywords: PM
Cc: testing@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible:

Description

Battery icon does not change immediately when plug USB or Charger.
Kernel: Image-2.6.24+git13+7b7d70785f1b3c1421d56ee8140578fea3b90f9c-r0-om-gta02.bin
Rootfsfilesystem :
Openmoko-openmoko-qtopia-x11-image-glibc-ipk-P1-Snapshot-20080520-om-gta02.rootfs.jffs2

step :

  1. Turn on Neo
  2. Plug the Charger or USB cable

Change History

comment:1 Changed 11 years ago by julian_chu

  • Status changed from new to closed
  • Version changed from unspecified to GTA02v5
  • Resolution set to fixed
  • Milestone set to ASU

comment:2 Changed 11 years ago by regina_kim

  • Cc will@… added

comment:3 Changed 11 years ago by regina_kim

  • Status changed from closed to reopened
  • Resolution fixed deleted

comment:4 Changed 11 years ago by julian_chu

  • Status changed from reopened to assigned
  • Priority changed from high to normal
  • Owner changed from julian_chu@… to zecke@…

comment:5 Changed 11 years ago by zecke

  • Cc raster@… added

I looked into this and it is complicated. The hardware gives us an event when we plug in a powersource (charger, usb cable) but we do not get any events when the PMU starts to charge or when the battery recognizes it is getting charged.

So we have probably these three alternatives and should settle for one:

a) Be happy that we will give instant charging feedback with the red led and just wait for the next poll interval of illume (e, batget)

b) When we get a power source insert event start a task to poll the battery for a couple of times to check if its state is changing (discharging -> charging, discharging -> full). From my attempts it looks like it is taking seconds (~3) before it is recognizing it is getting charged. The question is what do we win over the regular polling of illume (e, batget) as the charging feedback will not be instant

c) hack batget.c to show charging when a battery source got attached (even if it is not yet charging).

comment:6 Changed 11 years ago by zecke

  • Keywords PM added

Play with keywords.

comment:7 Changed 11 years ago by regina_kim

  • Component changed from ASU to System Software

comment:8 Changed 11 years ago by roh

  • Owner changed from zecke@… to zecke

comment:9 Changed 11 years ago by will

  • Status changed from assigned to in_testing
  • Cc testing@… added; buglog@…, will@…, raster@… removed

check if this is still the case.

comment:10 Changed 11 years ago by regina_kim

  • Status changed from in_testing to closed
  • Resolution set to fixed

it becomes better .

Note: See TracTickets for help on using tickets.