Ticket #1422 (closed defect: fixed)

Opened 11 years ago

Last modified 10 years ago

Device doesn’t wake up from blank time when incoming a call and SMS

Reported by: regina_kim@… Owned by: zecke@…
Priority: high Milestone: Om2008.9
Component: Qtopia Version: GTA02v5
Severity: normal Keywords: keep watching
Cc: buglog@…, will@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible: always

Description

Device doesn’t wake up from blank time when incoming a call and SMS

Kernel: Image-2.6.24+git13+7b7d70785f1b3c1421d56ee8140578fea3b90f9c-r0-om-gta02.bin
Rootfsfilesystem :
Openmoko-openmoko-qtopia-x11-image-glibc-ipk-P1-Snapshot-20080520-om-gta02.rootfs.jffs2

step: 1.go to Power and select the Blank time

2.incoming a call or receive SMS when blank time come

Change History

comment:1 Changed 11 years ago by julian_chu

  • Status changed from new to closed
  • Version changed from unspecified to GTA02v5
  • Resolution set to fixed
  • Milestone set to ASU

comment:2 Changed 11 years ago by will

  • Cc will@… added

comment:3 Changed 11 years ago by regina_kim

  • Component changed from ASU to Qtopia

comment:4 Changed 11 years ago by regina_kim

  • Status changed from closed to reopened
  • Resolution fixed deleted

comment:5 Changed 11 years ago by regina_kim

  • Status changed from reopened to assigned
  • Owner changed from julian_chu@… to zecke@…

comment:6 Changed 11 years ago by zecke

why was that reopened? Did the device wakeup at all? did the device wake up but didn't show any notification?

If that happens:

sudo ifconfig usb0 192.168.0.200 up
ssh root@192.168.0.202
logread

and please attach the output to this bug.

comment:7 Changed 11 years ago by regina_kim

  • Status changed from assigned to in_testing

because even sometimes wake up, sometime wake up and goes sleep again.
i could not check with today's image.

i will test with tomorrow.

comment:8 Changed 11 years ago by regina_kim

  • Status changed from in_testing to assigned

kernel : 20080723-asu.stable-uImage.bin
rootfs : 20080806-asu.stable-rootfs.jffs2

i tested with above image today.
it will wake up when incoming a call and goes into sleep again.
is that behavior for saving power ?

comment:9 Changed 11 years ago by zecke

So it goes to sleep during a call? Is that the first boot of the device? Could you reboot and check if that is still the case?

comment:10 Changed 11 years ago by zecke

Also were you able to answer the call? did you see the callscreen? could you pick it up? what was your blank time set to?

comment:11 Changed 11 years ago by regina_kim

i tested with first boot and first call after flash new image.
but second call is ok (not go into sleep anymore)
i Pick up and can hear well.
i did not touch anything for blank time.

comment:12 Changed 11 years ago by regina_kim

  • Status changed from assigned to in_testing

i will keep watching ticket.

comment:13 Changed 11 years ago by will

  • Milestone changed from Om2008.8 to Om2008.9

comment:14 Changed 11 years ago by regina_kim

  • Keywords keep watching added

comment:15 follow-up: ↓ 17 Changed 11 years ago by regina_kim

  • Reproducible set to always

kernel : 20080806-asu.stable-uImage.bin
rootfs : 20080814-asu.stable-rootfs.jffs2

it wakes up then goes to sleep again even re-boot(No.106,129,132)

comment:16 Changed 11 years ago by regina_kim

  • Status changed from in_testing to assigned

comment:17 in reply to: ↑ 15 ; follow-up: ↓ 18 Changed 11 years ago by zecke

Replying to regina_kim:

kernel : 20080806-asu.stable-uImage.bin
rootfs : 20080814-asu.stable-rootfs.jffs2

it wakes up then

that is a contradiction to the bug title. So it does wakeup from suspend on a incoming call and SMS?

goes to sleep again even re-boot(No.106,129,132)

And it goes back to suspend? Before you have seen the callscreen? Before you have heard the SMS notification? Is SMS and CallScreen? behaving differently? What is the blanktime set to? Does the screen keep black?

I wonder what the bug is as my device wakes up reliable on phone calls and SMS...

comment:18 in reply to: ↑ 17 Changed 11 years ago by regina_kim

Replying to zecke:

Replying to regina_kim:

kernel : 20080806-asu.stable-uImage.bin
rootfs : 20080814-asu.stable-rootfs.jffs2

it wakes up then

that is a contradiction to the bug title. So it does wakeup from suspend on a incoming call and SMS?

yes

goes to sleep again even re-boot(No.106,129,132)

And it goes back to suspend?

yes

Before you have seen the callscreen?
Before you have heard the SMS notification?
Is SMS and CallScreen? behaving differently?
What is the blanktime set to?

device does not have blnaktime setting function
so i did not set anything

Does the screen keep black?

yes after go into sleep

I wonder what the bug is as my device wakes up reliable on phone calls and SMS...

so should i close ticket and create new ticket ?

comment:19 follow-up: ↓ 20 Changed 10 years ago by regina_kim

  • Status changed from assigned to closed
  • Resolution set to fixed

someone create new ticket for this issue.

so i want close this ticket.

comment:20 in reply to: ↑ 19 Changed 10 years ago by regina_kim

Replying to regina_kim:

someone create new ticket for this issue.

so i want close this ticket.

The ticket No.#1792

Note: See TracTickets for help on using tickets.