Ticket #1430 (closed defect: fixed)

Opened 11 years ago

Last modified 11 years ago

diversity-nav has been already installed but packagekit will report that available

Reported by: tick@… Owned by: thomas@…
Priority: high Milestone:
Component: ASU Version: unspecified
Severity: normal Keywords:
Cc: buglog@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible:

Description

opkg 4452
It's seem packagekit will search for the first matched only.
And so that it will not found that the diversity-nav is installed.

root@om-gta02:~# pkcon search name diversity-nav
available diversity-nav-0.0.1+svnr360-r4
installed diversity-nav-0.0.1+svnr388-r3.03
available diversity-nav-dbg-0.0.1+svnr360-r4
available diversity-nav-dev-0.0.1+svnr360-r4
available diversity-nav-locale-fr-0.0.1+svnr360-r4
available diversity-nav-locale-it-0.0.1+svnr360-r4

root@om-gta02:~# pkcon search group communication
available diversity-nav-0.0.1+svnr360-r4
available openmoko-contacts2-0.1.0+svnr419-r4.01
available openmoko-dialer2-1:0.1.0+svnr4364-r7.01
available openmoko-messages2-0.1.0+svnr4340-r0.01
search-group runtime was 0.4 seconds

Change History

comment:1 Changed 11 years ago by tick@…

packagekit patches to d1e096c3267c1c9492041382b954e9327bc8bbec

comment:2 Changed 11 years ago by thomas@…

Search group returns all packages where the group tag matches the request group,
so it should not matter that two packages have the same version.

comment:3 Changed 11 years ago by thomas@…

  • Status changed from new to closed
  • Resolution set to fixed

I think this issue is closed now, because the old version did not contain the
correct groups tag.

Note: See TracTickets for help on using tickets.