Ticket #1431 (closed enhancement: community)

Opened 10 years ago

Last modified 10 years ago

ASU on GTA01: every QT application segfaults

Reported by: danielmewes@… Owned by: Nytowl
Priority: high Milestone:
Component: Autobuilds / Snapshots Version: unspecified
Severity: critical Keywords:
Cc: buglog@…, danielmewes@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: no PatchReviewResult:
Reproducible:

Description

I installed the following images onto my Neo GTA01:
http://buildhost.openmoko.org/daily/neo1973/deploy/glibc/images/neo1973/Openmoko-openmoko-qtopia-x11-image-glibc-ipk-P1-Snapshot-20080524-om-gta01.rootfs.jffs2
http://buildhost.openmoko.org/daily/neo1973/deploy/glibc/images/neo1973/uImage-2.6.24+git20080524-r0-om-gta01.bin

While the system boots fine and illume seems to work very well too, every QT
application I'm trying to start produces a SEGMENTATION FAULT.

Example:
(ssh to phone)
# export DISPLAY=:0.0
# clock
ApplicationLayer?: Unable to connect to server, application layer will be disabled.
qstring_to_xtp result code -2
qstring_to_xtp result code -2
Segmentation fault

I'm not sure whether those ApplicationLayer? errors have anything to do with
this, but I guess not, since I saw other Qtopia apps that do not produce any
error messages but segfault anyway. This even happens with qpe, however qpe
manages to run for a few seconds before it crashes (perhaps it crashed as soon
as it tries to display something, e.g. PIN dialog?).

The last lines of "strace clock" are
gettimeofday({1211965909, 177653}, NULL) = 0
gettimeofday({1211965909, 184003}, NULL) = 0

For qpe those interestingly are the same:
gettimeofday({1211965993, 912695}, NULL) = 0
gettimeofday({1211965993, 919445}, NULL) = 0

I also did an "strace -e write qpe" to monitor the modem interaction:
write(13, "-16\n", 4) = 4
write(13, "\371\3\357\5\303\1\362\371\r", 9) = 9
write(13, "AT+CMUX=0,0,5,31", 16) = 16
write(13, "\r", 1) = 1
write(13, "AT+CGMI", 7) = 7
write(13, "\r", 1) = 1
write(13, "AT+CBC\r", 7) = 7

After the following writes (which obviously do not go to the modem), qpe crashed
then:
write(21, "\0", 1) = 1
write(21, "AUTH EXTERNAL 30\r\n", 18) = 18
write(21, "BEGIN\r\n", 7) = 7

perhaps this can give a hint where in the code the error occurs...

Since some people reported ASU working on GTA02, i guess that there is some
build problem with a library or so in the buildsystem regarding the GTA01 build?
Or a problem when interacting with the (non accelerated) X server?

Change History

comment:1 Changed 10 years ago by john_lee@…

  • Owner changed from john_lee@… to julian_chu@…

comment:2 Changed 10 years ago by danielmewes

  • Cc danielmewes@… added
  • Type changed from defect to enhancement

I now built my own image using MokoMakefile? and this bug does not occur. Thus this clearly seems to be an issue with the build host.

comment:3 Changed 10 years ago by roh

  • Owner changed from julian_chu@… to julian_chu

comment:4 Changed 10 years ago by roh

  • Owner changed from julian_chu to Nytowl

maintainer change

comment:5 Changed 10 years ago by Nytowl

  • Status changed from new to closed
  • HasPatchForReview unset
  • Resolution set to community
Note: See TracTickets for help on using tickets.