Ticket #1435 (closed defect: worksforme)

Opened 9 years ago

Last modified 8 years ago

modem/kernel truncates packages in mux mode after hours of operation

Reported by: mdt@… Owned by: openmoko-kernel
Priority: high Milestone:
Component: hardware Version: GTA02v4
Severity: normal Keywords:
Cc: buglog@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: no PatchReviewResult:
Reproducible:

Description (last modified by roh) (diff)

i receive the following packages from the modem in mux mode:

00000000: 7e 05 ef 0d 0a 2b 43 50-42 53 3a 20 28 22 45 4e ~.ï..+CPBS: ("EN
00000010: 22 2c 22 42 44 22 2c 22-46 44 22 2c 22 44 43 22 ","BD","FD","DC"
00000020: 2c 22 4c 44 22 2c 22 52- . . . . . . . . ,"LD","R

00000000: 7e 05 ef 0d 0a 2b 43 47-4d 49 3a 20 46 49 43 2f ~.ï..+CGMI: FIC/
00000010: 4f 70 65 6e 4d 6f 6b 6f-0d 0a df 7e 7e 05 ef 0d OpenMoko?..ß.ï.
00000020: 0a 4f 4b 0d 0a df 7e .- . . . . . . . . .OK..ß~

as you can see, the first block does not end with an 0x7e which is the package
end byte. the second block is again a complete package with 0x7e at the
beginning and the end.

this behavior starts after hours of operation and increases.

Change History

comment:1 Changed 9 years ago by roh

  • Owner changed from sean_chiang@… to sean_chiang

comment:2 Changed 9 years ago by roh

  • Status changed from new to assigned
  • Owner changed from sean_chiang to openmoko-kernel
  • Component changed from GSM Modem to hardware
  • Description modified (diff)

sounds like a calypso fw bug.

do you have any specifics about how to provoke this?

comment:3 Changed 8 years ago by mickey

  • Status changed from assigned to closed
  • HasPatchForReview unset
  • Resolution set to worksforme

Can't reproduce that. Please retry with MP hardware and reopen, if still a problem.

comment:4 Changed 8 years ago by mickey

moko11 firmware fixes some flow control issues.

Note: See TracTickets for help on using tickets.