Ticket #1442 (reopened defect)

Opened 6 years ago

Last modified 6 years ago

Dialing through the headset does not working

Reported by: regina_kim Owned by: graeme
Priority: normal Milestone: Om2008.8
Component: Qtopia Version: GTA02v5
Severity: normal Keywords:
Cc: will@…, zecke@…, graeme@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible:

Description

kernel : 20080608-uImage.bin
roof : 20080610-roofts.jffs2

summary : Dialing through the headset does not working

step:

  1. Plug headset
  2. go to Dialer screen
  3. input number then press call -> check the voice through headset


expected result : it should be worked through the headset

Change History

comment:1 Changed 6 years ago by regina_kim

  • Component changed from ASU to Qtopia

comment:2 Changed 6 years ago by julian_chu

  • Owner changed from julian_chu@… to graeme@…
  • Status changed from new to assigned
  • Version set to GTA02v5
  • Severity changed from critical to major
  • Priority changed from highest to high

comment:3 Changed 6 years ago by will

  • Cc will@… added

comment:4 Changed 6 years ago by roh

  • Owner changed from graeme@… to graeme

comment:5 Changed 6 years ago by zecke

  • Cc zecke@… added

Can we get someone to work on the state files please? #1442 and #1443 demand working on the state files.

comment:6 Changed 6 years ago by graeme

It seems qtopia is not loading gsmheadset.state when call is on headset. I can load it manually and headset seems to work.

comment:7 Changed 6 years ago by regina_kim

  • Status changed from assigned to closed
  • Resolution set to wontfix
  • Severity changed from major to critical

comment:8 Changed 6 years ago by michael

An explanation as to why this was changed to "wontfix" from Will:

There are 2 issues here, both Hardware and Software.

Even with the software fix (1442) there is still an issue with the hardware emitting noise.  
Another issue is the fact that we don't ship with headsets. 
There is a software fix lying around, as graeme has commented in the ticket, 
but it is not in yet.

By the way, anyone can re-open tickets at anytime if there is an interest or suggestions.

comment:9 follow-up: ↓ 10 Changed 6 years ago by candrews

How can this be wontfix because you don't ship with headsets?! You don't ship with a Wireless AP, but you support connecting to them. You don't ship with GPS antennae, but you support those. And you don't ship with bluetooth headsets - yet there are bugs open because those don't work right.

AND you actually do ship wired headsets. In the extras pack, you ship a wired headset and 3 extra batteries - I know because I have one.

This is a definitely software problem at the least, and if it is a hardware problem, I expect someone at FIC to provide a fix, because that means by hardware is defective, and I didn't get what I paid for.

AND one more thing - not just anyone can reopen a ticket - I don't have permission to.

comment:10 in reply to: ↑ 9 Changed 6 years ago by will

  • Cc graeme@… added
  • Priority changed from high to normal
  • Status changed from closed to reopened
  • Resolution wontfix deleted
  • Severity changed from critical to normal

Replying to candrews:

This is a definitely software problem at the least, and if it is a hardware problem, I expect someone at FIC to provide a fix, because that means by hardware is defective, and I didn't get what I paid for.

AND one more thing - not just anyone can reopen a ticket - I don't have permission to.

Re-opening since there was some obvious miscommunication.
My mail to Michael was elusively used out of context. Read the message: 'there is a fix lying around' << i do not know where it is or heard of any sort of confirmation yet.

Graeme/Holger?, any clues?

Note: See TracTickets for help on using tickets.