Ticket #1447 (closed defect: fixed)

Opened 11 years ago

Last modified 11 years ago

it makes little bit noise when Device is Ringing

Reported by: regina_kim Owned by: zecke
Priority: highest Milestone: Om2008.8
Component: Qtopia Version:
Severity: blocker Keywords: must have
Cc: will@… Blocked By:
Blocking: #1640 Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible:

Description

kernel : 20080608-uImage.bin
roof : 20080610-roofts.jffs2

summary :
it makes little bit noise when Device is Ringing

step:
check when incoming a call

expected result :
it should be Ringing without any noise

Change History

comment:1 Changed 11 years ago by regina_kim

  • Milestone set to ASU

comment:2 Changed 11 years ago by zecke

The Qtopia ringtone is crap and the usage of gstreamer seems to be bad as well. Do we have any other ringtone?

comment:3 Changed 11 years ago by will

  • Cc will@… added

we can switch the ringtone, but are we sure it's only the ringtone?
can you switch to any mp3 file first, then confirm that it actually removes the noise?

comment:4 Changed 11 years ago by zecke

  • Owner changed from zecke@… to zecke
  • Status changed from new to accepted

This is more than just one single issue. I'm going to investigate this. It involves the audio code, gstreamer, and how Qtopia is driving gstreamer.
E.g. the code is using playbin of GStreamer which results in a five second latency to actually load the audio sample and start playing it.

comment:5 Changed 11 years ago by will

  • Keywords must have added
  • Severity changed from critical to blocker

comment:6 Changed 11 years ago by zecke

  • Blocking 1640 added

(In #1640) Adding "blocked by" the bugs will mentioned.

comment:7 Changed 11 years ago by zecke

We have changed the ringtone. There is still some issue with it but it is a huge progress. GStreamer or our audio hardware makes somethings up.

comment:8 Changed 11 years ago by zecke

  • Status changed from accepted to in_testing

comment:9 Changed 11 years ago by wendy_hung

  • Status changed from in_testing to closed
  • Resolution set to fixed

Tested with the image below:

kernel:20080723-asu.stable-uImage.bin
root file system:20080725-asu.stable-rootfs.jffs2

ring tone changed, and in this image the tone is not "shaking"
close this bug, thank you!

Note: See TracTickets for help on using tickets.