Ticket #1482 (closed defect: fixed)

Opened 10 years ago

Last modified 18 months ago

[oe]AUX bottom doesn't shine red light while charging

Reported by: wendy_hung Owned by: andy
Priority: high Milestone: Om2008.10
Component: kernel Version:
Severity: critical Keywords: Om2008.11
Cc: testing@…, openmoko-kernel@…, matt_hsu@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: no PatchReviewResult:
Reproducible:

Description

Kernel : 20080608-uImage.bin
Root file system : 20080610-rootfs.jffs2

results:
1.plug in charger/USB to neo
2.AUX light did not shine

Expected Value :
Plug in the charger/USB the AUX bottom should shine red lights till full charged.

Change History

comment:1 Changed 10 years ago by wendy_hung

Kernel : 20080621-asu.stable-uImage.bin
Root file system :20080623-asu.stable-rootfs.jffs2

We are still not getting any red light indication when usb/charging is plugged in.
Any updates?

comment:2 Changed 10 years ago by roh

  • Owner changed from andy@… to andy

comment:3 Changed 10 years ago by will

  • Cc testing@… added; will@…, regina_kim@… removed
  • Keywords must have added
  • Severity changed from major to blocker
  • Priority changed from high to highest

We have to get this in ASU.
I've only seen it working once or twice in the dev build.
I think it may be lost somewhere..

comment:4 Changed 10 years ago by julian_chu

  • Owner changed from andy to julian_chu
  • Status changed from new to assigned
  • Priority changed from highest to normal
  • Summary changed from AUX bottom doesn't shine red light while charging to [oe]AUX bottom doesn't shine red light while charging

I will fix it by these steps...

root@om-gta02:/sys/devices/platform/gta02-led.0/leds/gta02-aux:red# echo bat-charging > trigger

comment:5 Changed 10 years ago by will

This is still unstable. Light is not shining everytime, sometimes it continues to shine even after pulling out the charger.
Am I missing something here? Is this working for you guys?


comment:6 Changed 10 years ago by wendy_hung

Test with the image below:

kernel:20080720-asu.stable-uImage.bin
root file system:20080721-asu.stable-rootfs.jffs2

Will happened some results as fallowing:

1) shine red light and charging icon ----> rarely happened
2) no red light but charging icon -----> almost happened every time, just like before
3) shine red light after plug out charger/USB -----> plug in charger/USB again red light will disappear

comment:7 follow-up: ↓ 8 Changed 10 years ago by andy

Yes charging in general is royally FUBAR'd at the moment, it is getting looked at. Whether the light is telling the truth about charging state and it really is that bad is the question.

comment:8 in reply to: ↑ 7 Changed 10 years ago by will

Replying to andy:

Yes charging in general is royally FUBAR'd at the moment, it is getting looked at. Whether the light is telling the truth about charging state and it really is that bad is the question.

Hi Andy,
I've seen a lot of information passed around on this, but nothing concrete.
Any updates?

comment:9 Changed 10 years ago by andy

This should be solved in tomorrow's kernel package from stable branch.

comment:10 Changed 10 years ago by wendy_hung

  • Status changed from assigned to in_testing

Thanks andy, put that in to in_testing, will test that later.

comment:11 Changed 10 years ago by regina_kim

  • Priority changed from normal to high
  • Severity changed from blocker to critical

comment:12 Changed 10 years ago by andy

The priority going up has some meaning about testing results, or testing didn't happen yet?

comment:13 Changed 10 years ago by wendy_hung

  • Status changed from in_testing to assigned

Sorry that did not reply it immediately, we want to make sure the image is the one that we want.

Tested with the image below:
kernel:20080808-asu.stable-uImage.bin
root file system:20080807-asu.stable-rootfs.jffs2

It seems like the device can't charge at all, the device act as below:
1) show up charging icon all the time, even after flash the new image
2) does not shine red light when I plug in USB/charger (not always)
3) shine the red light but stop after few minutes, i think might be full charged so take the battery out (charger/USB still plug in) but the device shot down.

comment:14 follow-up: ↓ 15 Changed 10 years ago by andy

Just before I went to bed Raster told me about the last changes not giving him "discharging" status but "not charging", I'll fix that today: that is 1) issue. Otherwise, I sat here for some time pushing and pulling the USB and waiting for the light to go out, monitoring current at the battery and it was OK.

2) can be real charger decision or error on my side. To confirm it, you can do

cat /sys/devices/platform/bq27000-battery.0/power_supply/bat/current_now

if the number is negative, it truly charges the battery. But the number can be 4 -5 seconds old, so bear this in mind.

3) is correct for the light, it did stop charge. Taking battery out -> shutdown seems to be separate hardware problem we had for 6 months.

comment:15 in reply to: ↑ 14 Changed 10 years ago by wendy_hung

Replying to andy:

3) is correct for the light, it did stop charge. Taking battery out -> shutdown seems to be separate hardware problem we had for 6 months.

For this, before this image, if I plug in USB/charger then I can take out the battery without any effects(won't shotdown). Not now anymore, did I misunderstand something?

comment:16 Changed 10 years ago by andy

There is a window that the device will stay up without a battery, then it will shutdown, it has been this way for a long time.

You cannot boot without a battery either.

Unless this got better on A6 or something that is how it is with GTA02.

comment:17 Changed 10 years ago by will

  • Milestone changed from Om2008.8 to Om2008.9

comment:18 Changed 10 years ago by wendy_hung

Test with the image:
kernel:20080808-asu.stable-uImage.bin
root file system:20080825-asu.stable-rootfs.jffs2

the act now is :
1) plug in USB will work very good, with aux red light and charging icon show up no matter if it's suspend or not
2) plug in charger while it's not suspending--no red light no charging icon but the battery icon will become full if it's full charged
3) plug in charger while it's in suspending-- resume with aux red light and charging icon

comment:19 Changed 10 years ago by tick

  • Owner changed from julian_chu to andy

comment:20 Changed 10 years ago by tick

Change ticket to the actual owner/solver

comment:21 Changed 10 years ago by will

  • Cc matt_hsu@… added
  • Milestone changed from Om2008.9 to Om2008.10

matt hsu stated there is patch for this?
Is it on the way?

comment:22 Changed 10 years ago by andy

Yes, Matt's patch went into stable kernel yesterday. But, it only affects wallcharger, and the fix not quite complete. Still, it can be the cause of charger-only problems with this.

comment:23 Changed 10 years ago by wendy_hung

  • Keywords Om2008.11 added; must have removed
  • HasPatchForReview unset

comment:24 Changed 10 years ago by andy

  • Status changed from assigned to closed
  • Resolution set to fixed

This was solved by Balaji's pcf50633 rewrite in the meanwhile.

comment:25 Changed 18 months ago by Kennescoma

Viagra Giornaliero <a href=http://cial5mg.xyz/cheap-cialis-tablets.php>Cheap Cialis Tablets</a> Priligy Generico Zithromax Cost At Publix <a href=http://cial1.xyz/cheap-cialis.php>Cheap Cialis</a> Cost Of Propecia At Walmart Keflex 500 Mg Tabs <a href=http://viag1.xyz/map.php>Sildenafil</a> Puedo Tomar Viagra Aunque No Lo Necesite Cephalexin Sulfameth Trimethoprim Seborrheic Dermatitis <a href=http://viag1.xyz/china-viagra-online.php>China Viagra Online</a> Cialis Bestellen Mit Rezept Propecia Afectividad <a href=http://doxycycline.ccrpdc.com/doxycycline-dosage.php>Doxycycline Dosage</a> Special Care Pharmacy Puerto Rico Propecia Arranca <a href=http://cial1.xyz/buy-online-cialis.php>Buy Online Cialis</a> Zithromax Solubility Cephalexin Side Effects Stomach Pain <a href=http://cialis.ccrpdc.com/how-to-buy-cialis.php>How To Buy Cialis</a> Cephalexin With No Presciption Clomid Apres 10 Jours <a href=http://prozac.ccrpdc.com/order-prozac-online.php>Order Prozac Online</a> Minoxidil Proscar Propecia Low Cost Viagara <a href=http://cial1.xyz/cialis-free-trial.php>Cialis Free Trial</a> Bewertung Levitra Free Shipping Acticin Where To Buy Overseas Next Day <a href=http://cial1.xyz/cialis-cost.php>Cialis Cost</a> Pharmacy Rx World Viagra Alcool Mort <a href=http://cial1.xyz/cialis-5mg.php>Cialis 5mg</a> Levitra Originale Prezzo Taking Both Cephalexin And Clindamycin <a href=http://propecia.ccrpdc.com/buy-propecia-online-safe.php>Buy Propecia Online Safe</a> Viagra With Dapoxetine

Note: See TracTickets for help on using tickets.