Ticket #1489 (closed defect: fixed)

Opened 6 years ago

Last modified 6 years ago

sometimes volume is too low during a call

Reported by: regina_kim Owned by: tick
Priority: high Milestone: Om2008.9
Component: hardware Version:
Severity: critical Keywords: Om2008.11
Cc: testing@…, teenie_hung@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: no PatchReviewResult:
Reproducible:

Description

kernel : 20080611-asu.stable-uImage.bin
rootfs : 20080619-asu.stable-rootfs.jffs2

summary : sometimes voice is too small during calling

step :

  1. incoming a call
  2. answer call
  3. check the voice

current result : voice is small

expected result : need more clear voice

Change History

comment:1 Changed 6 years ago by roh

  • Cc will@… added; will@… removed

comment:2 Changed 6 years ago by will

  • Component changed from Qtopia to hardware

hardware + alsa file

comment:3 Changed 6 years ago by roh

  • Owner changed from zecke@… to zecke

comment:4 Changed 6 years ago by regina_kim

kernel : 20080705-asu.stable-uImage.bin
rootfs : 200807014-asu.stable-rootfs.jffs2

voice is really too small when third parties call activate connecting(when join three calls)

comment:5 Changed 6 years ago by will

  • Cc testing@…, teenie_hung@… added; will@…, wendy_hung@… removed

please just forget about third party calls for now.
we do not want this.
this ticket is about sound volume, which as i understand there is not much we can do until we see where hardware take us in A7.
So please wait.
(teenie, you were cc'ed. Who is the appropriate owner of this ticket?)

comment:6 Changed 6 years ago by regina_kim

  • Priority changed from normal to high

comment:7 Changed 6 years ago by regina_kim

hey will

why i mentioned third parties call because after connected third parties call sound become more lower than just call.

comment:8 Changed 6 years ago by regina_kim

  • Milestone changed from Om2008.8 to Om2008.9

comment:9 Changed 6 years ago by john_lee

  • Status changed from new to in_testing
  • HasPatchForReview unset

we modified alsa state recently. please check if this is still the case in one on one call. please also notice that the audio quality may varies on different neo.

comment:10 Changed 6 years ago by regina_kim

Wendy got new device which is different version of hardware board.

Wendy Please check this ticket on Monday. thanks.

comment:11 Changed 6 years ago by wendy_hung

  • Status changed from in_testing to assigned
  • Owner changed from zecke to john_lee

I have A7 in my hand, i test it during the weekend.
I would say the voice is super small when i use the phone. The voice sounds like form far far away and the person you're talking to even wear a mask.
I'm at home, and i have to ask my friend to yell to me...so don't even mention when i'm in Taipei mrt system...

I try use alsamixer to change the voice but happened nothing.
Headphon is 100/100 from beginning...

A5's problem is every phone might have different result, but in A7 it seems all the same--voice still too small. (at least until now..)

comment:12 Changed 6 years ago by wendy_hung

  • Keywords Om2008.11 added

comment:13 Changed 6 years ago by john_lee

  • Summary changed from sometimes voice is too small during calling to sometimes volume is too low during a call

comment:14 Changed 6 years ago by john_lee

  • Owner changed from john_lee to tick

tick will implement a volume bar in qtopia call screen to solve the this. please change this to in_testing after you finished the implementation.

comment:15 Changed 6 years ago by tick

  • Status changed from assigned to in_testing

comment:16 Changed 6 years ago by wendy_hung

  • Status changed from in_testing to closed
  • Resolution set to fixed

tested with image below:
kernel:testing-om-gta02-20081210.uImage.bin
rootfs:openmoko-testing-om-gta02.rootfs.jffs2 (20081210)

The volume bar works now, this problem should solved.

comment:17 Changed 6 years ago by wilk

I was thinking we could make the sound volume setting persistent from one call to the next since usually it's very likely that if I previously increased the volume, I will have to increase the volume again at next call which is not very convenient since sliding the bar is not very convenient during a call (see http://docs.openmoko.org/trac/ticket/2188).

Note: See TracTickets for help on using tickets.