Ticket #1491 (closed enhancement: fixed)

Opened 11 years ago

Last modified 11 years ago

Refresh Cache crashes Assassin when there is no WiFi

Reported by: wendy_hung Owned by: tick
Priority: high Milestone: Om2008.8
Component: Installer Version:
Severity: critical Keywords:
Cc: regina_kim@…, will@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible:

Description

kernel : 20080611-asu.stable-uImage.bin
rootfs : 20080619-asu.stable-rootfs.jffs2

1) Launch Assassin with no connection to wifi
2) Refresh Cache message continues for 5.35sec
3) 'Fatal: System timeout!' message shows
4) After pressing 'ok' , progress bar still runs behind list view (please see attachment)

Expected Value:

1) Launch Assassin with no connection to wifi
2) 'Refresh Cache' message continues for less than 5 sec
3) 'Error' message says, 'please connect to WiFi?'
4) After pressing 'ok', goes to regular Assassin list view

Attachments

assassin_crash.png (200.0 KB) - added by wendy_hung 11 years ago.

Change History

Changed 11 years ago by wendy_hung

comment:1 Changed 11 years ago by tick

  • Owner changed from tick@… to tick
  • Status changed from new to accepted

This should be caused by the packagekitd crashed while initialing opkg.

opkg_new returns NULL and cause packagekit crashes, and return NULL pointers.

When Assassin try to access packagekit, and packagekit crashes all the time. and after a while dbus is unstable too.

This bug was introduced in opkg svn 4466.
And solved at opkg svn 4491.

After opkg has been update to 4491 this issue can be switch to in_testing.

comment:2 Changed 11 years ago by tick

  • Status changed from accepted to in_testing

comment:3 Changed 11 years ago by wendy_hung

  • Status changed from in_testing to assigned
  • Type changed from defect to enhancement

Tested with the image below

Kernel : 20080621-asu.stable-uImage.bin
Root file system :20080630-asu.stable-rootfs.jffs2

'Refresh Cache' message continues for less than 5 sec (2~3 sec)
But regular Assassin list come out need 6 sec
Please make it faster

comment:4 Changed 11 years ago by tick

  • Status changed from assigned to in_testing

It's another issue.
If the main point of this issue solved, please close it.
If you think the second issue is really an issue, please create a new ticket.
Thanks

comment:5 Changed 11 years ago by wendy_hung

  • Status changed from in_testing to closed
  • Resolution set to fixed

test with the image below
kernel:20080717-asu.stable-uImage.bin
root file system:20080717-asu.stable-rootfs.jffs2

the problem become another issue come out, will open another ticket for it.

thanks!

Note: See TracTickets for help on using tickets.